Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Windows 7 onto this IDE hard drive and everything looked good. It went through the entire process until that regular last boot after "Completing installation...".

But it won't boot into the hard drive, no matter the boot order. It just says "AMD Data Change...Update New Data to DMI!" and just hangs there.

The drive is set to cable select and I can tell it's master because of the boot messages:

IDE Channel 0 . Master Disk  HDD S.M.A.R.T. capability .... Disabled

When I change the position of the hard drive on the cable, that "Master" becomes "Slave". So I know it's the master drive.

I've removed the DVD-ROM drive from the situation by unplugging it and setting "Hard Drive" as the first in the BIOS boot order.

Why is it not booting?

EDIT I ran Windows 7 Startup Repair and it didn't detect any problems. Hm.

EDIT: I just replaced the IDE drive with a SATA one (different drive, cable, port, and protocol), installed Windows 7 on it, then rebooted to the same problem.

EDIT: I loaded the BIOS's optimized defaults and it fixed nothing.

EDIT: I loaded the BIOS's fail-safe defaults and it fixed nothing.

EDIT: I changed out the memory and put it into a new seat and nothing got fixed.

EDIT: This is the motherboard: Sapphire PI-AM2RS780G

share|improve this question
    
"The drive is set to cable select and I can tell it's master because of the boot messages:" I would set the jumper to "master" position. –  Aki Oct 8 '11 at 17:10
    
@Aki, I did that and got the same result. –  Matt Alexander Oct 8 '11 at 17:15
    
My IDE HD is set to "master" and the DVD-ROM that shares the cable is set to "slave". It works. Mysterious. –  Aki Oct 8 '11 at 17:23
    
Tell me about your Windows 7 disc. Where did you get it from? Is it an ISO? Does it contain SP1 on it, or is it just Windows 7 itself? –  H3br3wHamm3r81 Oct 18 '11 at 1:00

2 Answers 2

Other people with a very similar problem reported that it can be overcome by one of:

  • enabling ACPI in the BIOS.
  • loading optimized defaults in the BIOS
  • changing the drive cable (it was SATA though)

A GigaByte motherboard FAQ allegedly says:

Q:When switching on the PC there is always a message at BIOS POST "K8 NPT Data change... Update New Data to DMI", what does this message mean?

A:It means that data of the memory registry of K8 processor has been updated to DMI when the system is turned on. Those data are aimed to be written back to processor when PC wakes up from sleep mode of S3(STR).

share|improve this answer
    
ACPI is already enabled. –  Matt Alexander Oct 8 '11 at 17:27
    
I loaded the failsafe defaults. –  Matt Alexander Oct 8 '11 at 17:43
    
@mattalexx: What I read suggests that there is also "optimized defaults" - I don't have a Gigabyte mobo though so can't easily check. Maybe if you update your question with more details of Motherboard, BIOS version, Disk model#, etc, someone else may be able to help. Is the HDD a new one? –  RedGrittyBrick Oct 8 '11 at 17:52
    
I just reset the BIOS to its optimized defaults and it didn't change anything. –  Matt Alexander Oct 8 '11 at 18:34
    
I just replaced the IDE drive with a SATA one, installed Windows 7 on it, then rebooted to the same problem. –  Matt Alexander Oct 8 '11 at 18:35
up vote 1 down vote accepted

I replaced the motherboard and everything started working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.