Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Does anyone know how to get the temperature of an Intel Core i5 processor in FreeBSD?

Relevant info:

  • Motherboard: Asus P8P67 Deluxe
  • CPU: Intel(R) Core(TM) i5-2500
  • OS: FreeBSD 8.2-RELEASE (64bit)

I've tried:

  • sysctl -a ⇒ nothing about CPU-temp there
  • mbmon ⇒ outputs: No Hardware Monitor found!! InitMBInfo: Unknown error: 0

I've successfully used mbmon on previous rigs with older hardware, but I can't get it to work with this setup. I've tried all "access methods" (options -V, -S, -I, -A).

share|improve this question
    
You may need to load smbus (kldload smbus) and/or other modules to get mbmon to work. It depends on the chipset. –  Chris S Oct 9 '11 at 1:44

1 Answer 1

up vote 6 down vote accepted

Try this:

% kldload coretemp
% sysctl -a |grep temper
dev.cpu.0.temperature: 60
dev.cpu.1.temperature: 60
dev.cpu.2.temperature: 64
dev.cpu.3.temperature: 64

Also check if FreeBSD has modules for your ACPI-chip:

ls /boot/kernel |grep ^acpi
acpi.ko
acpi_aiboost.ko
acpi_asus.ko
acpi_dock.ko
acpi_fujitsu.ko
acpi_ibm.ko
acpi_panasonic.ko
acpi_sony.ko
acpi_toshiba.ko
acpi_video.ko
share|improve this answer
    
please mark it as accepted so it appears answered :) thanks –  Franz Bettag Oct 9 '11 at 1:44
    
Perfect, kldload coretempdid it. Thank you very much! (And yes, I try to always accept when I've received the best answer :-) –  poplitea Oct 9 '11 at 2:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.