Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I click on my computer I can see a list of drives etc. But when I click on them I get the "Open With" dialog box. I've tried the drive association fix mentioned here. It didn't work.

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

Bit of a random fix, but it worked wonders for a colleague who had the exact same problem:

  1. Click Start
  2. Click Run
  3. Type cmd and click OK to bring up the command prompt
  4. Type attrib -r -s -h c:\autorun.inf and press Enter
  5. Type del c:\autorun.inf and press Enter

If it works, repeat steps 4-5 for each drive substituting c: for d: or e: or whatever other drives you have.

If not, the other fix which I have seen used for problems similar to this is:

  1. Click Start
  2. Click Run
  3. Type regsvr32 /i shell32.dll and click OK twice
share|improve this answer
    
does ur first solution require a restart or anything? –  deostroll Sep 2 '09 at 18:51
    
The first fix is immediate whereas a restart would be a good idea for the second fix, just to make sure. –  Kez Sep 2 '09 at 19:03
    
Ur first fix wasn't immediate. I think the 2nd fix worked somehow. Any idea wht tht does? –  deostroll Sep 3 '09 at 6:23
    
It just re-registers the DLL that contains information about the Windows interface. Think of the above command as a little reset button. Some more background info here: pcworld.com/article/126116/… –  Kez Sep 3 '09 at 7:11
add comment

Start Registry Editor. (start -> Run... -> regedit)

navigate to:

HKEY_CLASSES_ROOT\Drive\shell

Set (default) to "none" (without ")

Click OK.

Quit Registry Editor.

edit: If this problem is also related to folders, then start Registry Editor. (start -> Run... -> regedit)

navigate to:

[HKEY_CLASSES_ROOT\Directory\shell]

Set (default) to "none" (without ")

Click OK.

Quit Registry Editor.

share|improve this answer
    
The drive association fix mentioned in the question already does this. –  Kez Sep 2 '09 at 18:35
    
well, if the {default} key is set to NONE, then doubleclick will just OPEN the drives and not perform ANY other action. if the problem persists then you might be in for a thorough malware check and/or system restore. –  Molly7244 Sep 2 '09 at 18:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.