Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A $ shows up at the end of every line when I'm using vim and I'm not able to figure out what in my vimrc is causing this. Heres a picture and my entire vimrc below it. What could it be?

enter image description here

set listchars=tab:>-,eol:$,trail:-,precedes:<,extends:>

Edited above to remove the irrelevant lines.

share|improve this question
up vote 3 down vote accepted

This line

set listchars=tab:>-,eol:$,trail:-,precedes:<,extends:>

is denoting the end-of-line and trailing whitespace with $ and -. Comment the line out with " or remove the eol portion.

share|improve this answer
    
Yup ofcourse, thanks. – sri Oct 9 '11 at 6:38

You don't say whether you actually want "list" mode for some reason. I usually only use it when needed and normally have it turned off.

I would change

set list

To

set nolist

I expect to see $ at end of line when using list-mode in vi family editors.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .