Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I start Windows XP SP2, not always - but many times - it shows me a frustrating dialog that new hardware has been found but it is not installed properly so it won't work. Its name is also confusing. I haven't installed anything, there is nothing new.

enter image description here

One change which has occurred is that my DVD drive is not working. It doesn't open. but that's not a problem. The main problem is seeing this dialog so often when I start my computer. Even if I disable or uninstall it from there it still appears again automatically.

Sometimes when I start Windows it will only get up to the "Welcome" screen and will then hang - it doesn't show the username/password screen.

share|improve this question

1 Answer 1

Either your computer is infected, or some device driver has been badly installed.

You could maybe restore your system to a time before this started, but it would perhaps be better to first investigate this strange device.

To do that, in Device Manager right-click on the device and choose Properties, then to the Details tab. In the Property drop-down box, choose Hardware Ids. It should look some thing like this : USB\VID_0BDA&PID_8187&REV_0100 (sometimes more than one is displayed).

[EDIT]

The Hardware Ids you found look to be semi-legitimate, but heavily garbled.

"Worm" probably stands for Write-Once-Read-Multiple. Such Ids are generated for example by USBSTOR.SYS.

In your case, this is clearly an IDE drive that is causing the problem. This can be either a CD/DVD drive that has gone bad or a hard disk (if you have IDE/ATA disks). As I believe that you would probably have noticed a missing hard disk, I would guess that the problem lies in the CD/DVD drive or in the driver.

As a test, I would open the computer (if you can), then disconnect the CD/DVD drive to see if the problem disappears. Disabling it in the BIOS might also be enough.

In any case, I would suggest upgrading to XP SP3 as soon as possible. This might refresh a malfunctioning driver and shock XP into working correctly. There are of course many other reasons to update to SP3.

But take serious backups before upgrading and ensure that you can reinstall XP and all applications. The best backup would be to take a disk image of the system drive.

If the upgrade fails, your computer may become unbootable. This may be because it was in fact really infected. In this case the best solution is to reformat the hard disk and reinstall everything.

share|improve this answer
1  
That might exist from a firmware corruption (rare). With it changing names each time, could be a cable. remove any external items, and see if it Ghosts out. remove the dvd and see if that was it. Whatever it is, you probably have other instances of it that are Hidden. Must do "Hidden devices tweak" and do a cleanup. Probability high that a new item is being added at each boot. –  Psycogeek Oct 9 '11 at 11:46
    
@harrymc Thanks for this really helpful answer. I did as you said & wondered Hardware IDs are showing 'worm'. I don't know whats this. System files or really a Worm!! Another thing to be wondered for is that now that hardware's name has changed. When I started my computer some minutes ago, 'found new hardware' dialog appeared again. Another thing I've noted in my computer is that when I ran virus scan for whole comp. it did not stopped even after completion & again started from begining :/ Here's what now I'm seeing - i.imgur.com/998eI.jpg –  SpAcE lOvEr Oct 10 '11 at 5:14
    
See my edit above. –  harrymc Oct 10 '11 at 6:24
    
@harrymc Hi harry, as you said I disconnected DVD drive from computer & one thing I noticed is that now 'other devices' option won't show up (as in above pic). May be now I'll not see that bad dialog again. It'll be proven after some further startups of my computer. As I said that my CD/DVD drive got damaged (I donno how) so I am unable to install SP3 (I have it in DVD. I know it can be downloaded but my net speed is too slow to do the job) nor I can repair or install any Window again nor I can backup anything as I always use DVDs to do any backup or make Images. BTW thanks 4 dis helpful post. –  SpAcE lOvEr Oct 11 '11 at 2:51
    
@harrymc You seems to be genius. |(( I thanks to God that my computer started & don't hanged. |( this is really a good site. –  SpAcE lOvEr Oct 11 '11 at 2:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.