Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having been getting a weird DNS response recently. If I ping any unresolved DNS (without tld, I.e. abc instead of abc.com), it will return the IP 72.167.34.97. If I would do it in the browser, it then redirect to telogis.com's login page.

I first notice this a month back in our office when I wanted to access the AP, but keyed in a wrong IP into the browser. It shows the telogis page. It was in the middle of mixing pfSense with Windows 2003 AD environment, thus I was assuming it's an configuration mistaken. After everything stabilized, I still bump into telogis page for this unresolved domain name, that's when I started to take notice. It would even redirect to telogis if I've misspelled the SharePoint server name in the browser.

I never heard of telogis before this. I've not installed anything from telogis as well. After much digging, I didn't find anything related to telogis or 72.167.34.97 recorded in registry or hosts file. This doesn't happen to my colleague. And it even happen to the same laptop when I'm online elsewhere.

Anywhere else I should be looking to remove this as it's starting to pose problem when I'm diagnosing a network issue, while Windows cache the unwanted DNS entries. Or anyone has a similar experience.

I'm running Windows 7 Ultimate x86 SP1, I'm 99.9% sure my laptop is free from spyware and viruses. Another side note, along the same time, I was migrating my local laptop profile to join the office's Windows 2003 AD domain. I've configured the NIC interface's DNS server to the AD in the office, router at home and ISPs elsewhere. Also, It won't resolved if I try to ping offline, which is expected.

EDIT: billc.cn for the nslookup tips. Now I've found out the culprit. Our office domain is xxx.com , which the domain will resolve to telogis' IP, but we're using it internally, which shouldn't be a problem, except for this particular one. Any DNS lookup to non-tld domain, ends up with domain.xxx.com, which in turn resolve back to telogis again. This is what nslookup return when I lookup for abc

C:\>nslookup acb
Server: unknown
Address: 192.168.1.1

Non-authoritative answer:
Name: telogis.com
Address: 72.167.34.97
Aliases: acb.xxx.com
         www.telogis.com

So this means that it should happen to all PC which has joint this domain. I've better double check again. Is there anyway to overcome this?

share|improve this question
1  
The moral of the story is the same as always: Don't steal someone else's domain name that you do not own (xxx.com. in this case) and use it as your own. Use a domain name that you yourself own. –  JdeBP Oct 10 '11 at 11:00
    
Well, we actually just wanted to use xxx as our domain, but windows made it xxx.com automatically. –  faulty Oct 11 '11 at 0:23
1  
You don't own xxx. either. That's owned by ICM Registry LLC. Stop stealing other people's domain names and you'll stop suffering this pain. –  JdeBP Oct 11 '11 at 14:47
add comment

2 Answers 2

up vote 1 down vote accepted

Do you have more than one active network connection or a working IPv6 link? You may have a differerent DNS setting elsewhere that is taking precedence over your main DNS setting. Run nslookup without any argument and see what is the default one your systme is using.

If the DNS is correct, it is possible some software registered a namespace in your system. Use netsh winsock show cata to view the installed ones.

share|improve this answer
add comment

It has to be a DNS suffix set in one of the adapters. Can you hit Start then type

view net

in the search box, and select view network connections. Go through the properties of each interface and check the properties of the ipv4 and ipv6 items. Look in Advanced, and the DNS tab, and look for the second box to see if it has any additional suffixes defined.

I am assuming you have already checked the ID of your computer, but if not, go to Start, then right-click Computer and select properties. See what domain is defined in the Computer Name section. If this is fine, then click Change Settings, then Change against "To rename...", then the More button, and see what the Primary DNS suffix is set to.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.