Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Related: Tried to use my 3TB drive in a USB enclosure, now reports only 746GB even internally

I originally solved the problem in the link above by deleting the partition table using GParted re-partitioning it.

However, now that I've filled 746GB of the drive I cannot add anymore files even though Windows 7 reports there are 2TB free but when I try to move any files over to it I get an error "The request could not be performed because of an i/o error"

enter image description here

share|improve this question
1  
do we laugh or cry? your data is mostly safe, as long as that same numbering system is used. it is likly you need a controller that can handle the bigger numbers, or uses cheap tricks to translate the sectors bigger so the other number is smaller. You will want to get your data off it witout moving off the controller, a different controler COULD use a different method, to get past the number issue. –  Psycogeek Oct 9 '11 at 16:35
    
Part of me wonders if removing the enclosure was really worth the price? :) –  surfasb Oct 10 '11 at 2:33
    
How so? The external enclosures just didn't support >2tb and falsely reported the free space. –  JaredMcAteer Oct 10 '11 at 13:07

3 Answers 3

up vote 8 down vote accepted
+25

First point: To support more than 2.2 GB, the disk must be formatted as GPT, not as MBR.

Second point: Even if the disk is formatted as MBR, you should be getting 2.2 TB, not 746 GB. The fact that this is not happening could point to a problem with the firmware.

You should first check for BIOS and USB controller firmware updates,as well as update for the USB mass storage driver.

In the case of the disk's firmware possibly being damaged, I hesitate whether to point you to the article Restore factory Hard Drive Capacity, since the utility described there can brick your drive. There is no guarantee that it will work correctly on your disk model.

This could also be a problem with the USB bridge on the motherboard, which problem belongs more in a computer repair workshop. Have you ever successfully used a USB with more than 746 GB on it ?

If the disk is still under warranty, it might be safer to exchange it for a new one.

[Edit]

Trying to analyze, the problem can only be :

  1. Windows driver
  2. disk firmware
  3. cable

The tests you can do :

  1. Check for Windows driver update (from disk manufacturer website), or try formatting and testing it on a recent Linux live CD
  2. Check for firmware update / ask vendor to replace the disk
  3. Try another cable of good quality

As a last resort, and only if the disk is exchangeable by the vendor if it becomes unusable, you could try the utility in the "Restore factory Hard Drive Capacity" article. I have already counseled it several times on this forum and it did the job, but this is always a risk.

But I must say that in view of your comment, this is looking more like a bad disk.

Question: What is the exact model of the disk ?

share|improve this answer
    
The GPT FAQ limits the MBR issue to Windows XP: "Windows XP supports only MBR partitioning on detachable disks. Later versions of Windows support GPT partitions on detachable disks." –  Robert Oct 12 '11 at 9:54
    
@Robert: You are right, USB is "detachable disk", while I confused it with "removable media" which refers more to flash-drives and cd/dvd. Updating answer. –  harrymc Oct 12 '11 at 10:04
1  
Disk is formatted as GPT, BIOS is Up to Date, this is not using USB, it's a SATA hdd connected to the motherboard. –  JaredMcAteer Oct 12 '11 at 14:03
    
See my edit above. –  harrymc Oct 12 '11 at 14:25

Since you're able to boot into Windows with a 3TB disk, I am assuming you're either using 64-bit Windows or have a smaller boot disk?

If it's the former, here's some of the possibilities I know:

  • BIOS bug. Check if the size of the disk is reported correctly in BIOS. Even with the latest version, there can still be bugs.
  • Disk controller driver. Always get the latest one directly from Intel or AMD or your controller card's manufacturer. Only recent versions of Intel Rapid Storage drivers support 3TB, so make sure you upgrade.

If it's the latter and/or you're using 32-bit Windows:

  • Make sure the partition table is in GPT.
  • Install the disk driver provided by your drive's manufacturer. (Disk drivers are not usually neede, but for 3TB drives they're important.)

Edit: Just to clarify. Windows is does not check partition tables very carefully, so what seems to be valid may not actually be usable. Linux does not have any problem supporting 3TB disks, so that's why you're able make a correct partition table with GParted.

In addition, it seems your 746GB problem is exactly the symptom of an Intel driver bug.

share|improve this answer
    
I am booting in on a 80gb disk which houses my Windows installation, the 3tb drive is simply a storage device. I am using Windows 7 x64. I'll check your suggestions when I get home. –  JaredMcAteer Oct 12 '11 at 16:53
    
Also see my edit. –  billc.cn Oct 12 '11 at 17:00
    

I had the same issue, this page had the answer:

The Intel RST version of 10.0.0.1046 it turns out is the culprit behind the 746GB available of the 3TB drive issue. For 3TB drive support, one should look to Intel RST 10.1 and newer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.