Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

there a tough one: I've bought a new computer with the following configuration:

ASUS Rampage III Extreme
Core i7 950
ZOTAC AMP! GeForce GTX 560
HAF 922

After installation of any Linux I can't launch it! After grub screen, when it's supposed to launch system it gets stuck with black-screen(debian) or purple-sceen(ubuntu).

I installed various versions of Ubuntu, Debian with and without X, Fedora. Every time it's the same: total freeze after grub.

Can anyone help me, please? I don't want to stuck with Windows (which is running perfectly as never)!

share|improve this question

closed as too localized by studiohack Mar 20 '12 at 14:58

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Install NVIDIA Linux display drivers!

Release Date: 2011.07.13

Added support for the following GPUs:

  • GeForce GTX 560
  • GeForce GT 545 ...
share|improve this answer
Please! I've already mentioned that i tried Debian without x-server. – seler Oct 10 '11 at 19:53
Unrelated. X or not X - add anyway, maybe - using second more light V/Card – Lazy Badger Oct 11 '11 at 0:35
How can i install drivers, when i even cant launch the system!? It freezes right after grub-screen! – seler Oct 11 '11 at 7:35
Show Grub config, obviously – Lazy Badger Oct 11 '11 at 8:48
How? It's all defaults. Freshly installed systems. – seler Oct 11 '11 at 9:42

Try switching to a console by pressing Ctrl + Alt + F2. If you can see the login prompt then this is a display driver issue. A common problem with Linux for new hardware.

If display driver is the issue go to the ASUS website and download the linux driver if they have it for your motherboard.

share|improve this answer
It wont even go that far. I mentioned before that I tried Debian without x-server. Also, ASUS Rampage III Extreme has no onboard graphics card. – seler Oct 10 '11 at 7:53

In case this is still an issue, try booting with a live CD (Ubuntu should work just fine), and check the latest logs in /var/log to see what happened during the last boot. It could be that some default setting or kernel version is not working for the given hardware.

share|improve this answer
I gave up long time ago. I'm running Debian as virtual machine. Thanks for trying :) – seler Mar 20 '12 at 14:47
@seler: Sorry to hear that. I've had problems with new hardware on Linux before, but usually some googling or a detailed SO question turns up a solution. – l0b0 Mar 20 '12 at 14:52
It's just there are no linux drivers for my build. – seler Mar 31 '12 at 12:46

Not the answer you're looking for? Browse other questions tagged .