Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For instance, if I have one or more of the following characters copied into clipboard, a paste into the terminal window will not work:

“ ” ’ –

This is pretty annoying, actually, one would think that it could be as smart as it just got rid of the characters in the paste maneuver but, it just doesn't paste anything in.

Could there perhaps be any way around this?

share|improve this question
    
I can't reproduce this – what exactly happens? Nothing? Which version of OS X are you on, just for clarification? –  slhck Oct 10 '11 at 14:19
    
Running 10.7 currently, problem has persisted since 10.5 for me. Correct, nothing happens when any of those characters are included in the clipboard. Most commonly I copy articles from the web and they tend to have those characters in them. –  Wrench Oct 10 '11 at 14:50
    
Where are you copying them to? Any specific text editor or does it generally apply to the any active process in the Terminal? –  slhck Oct 10 '11 at 14:52
    
I think I may have an explanation. I'm using ISO-latin-1 and that seem to be the problem. Using UTF-8 and it works. Too bad I need to use ISO-latin-1 though. –  Wrench Oct 10 '11 at 14:52
    
Oh, yes, that would have been my next guess. Why do you have to use it though? By the way, you can answer your own question if you want, explaining what you needed to change to fix it. This way you can help others and even gain reputation here. –  slhck Oct 10 '11 at 14:52

2 Answers 2

up vote 1 down vote accepted

The problem is that ISO-Latin-1 doesn't contain these characters: “ ” ’ –

They can't be translated to ISO-Latin-1, so the text cannot be sent to the terminal. If you Paste text containing them, the Paste does not happen. Similarly, if you type the characters on the keyboard, Terminal beeps.

…one would think that it could be as smart as it just got rid of the characters in the paste maneuver but, it just doesn't paste anything in.

Possibly, except that you wouldn't want it silently omitting a few characters here and there. Perhaps Terminal should display an alert if it can't translate the text, and possibly offer you the option of simply dropping the invalid characters.

If this is important to you, please file a bug report: http://developer.apple.com/bugreporter/

(If you don't already have one, it requires a developer account, but it's free.)

share|improve this answer
    
Actually I don't think my needs trumps anything here, I will just ask for UTF-8 support from the telnet BBS instead. :) THanks for your detailed answer! –  Wrench Oct 13 '11 at 14:54

Select a different encoding, like UTF-8, in the Advanced preferences of your Terminal profile:

enter image description here

In Terminal, you can assign different profiles to each tab, which can use different encodings. That way, you can keep using Latin-1 where needed, and have UTF-8 otherwise. You can select your profile in the New Window and New Tab sub-menus in the Shell menu item.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.