Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to dual boot Fedora and openSuse since I'm testing them out. I need a stable linux work machine for my thesis, and I'm wary of using the latest Ubuntu (Debian is a good candidate, but I am so unfamiliar with it) since Unity broke half of what I need. I might try out the 11.10 Ubuntu release on Thursday to see if Unity is fixed, but that's beside my issue.

[dev][partition type][label]
sda1    primary       DAMAGED
sda2    primary       BOOT
sda5    logical       SUSE
sda6    logical       swap
sda7    logical       TRANSIENT
sda8    logical       swap
sda9    logical       FEDORA
sda4    primary       DATA

Ok, so I've partitioned my hard disk so they may co-exist. Attached is my partition configuration. I only realised the issue when I ran openSuse's Live DVD: I don't have a 3rd device identifier. I know the quick fix is to reformat the entire thing so that the logical partitions are way back, but the partition labeled DATA contains information I would rather keep. I don't have an accessible back up drive yet, and would rather fix it without one.

Also, my hard disk is going bad because I unwittingly dropped it and now I have a whole streak of bad sectors isolated at sda1.

How may I go about it?

share|improve this question

migrated from stackoverflow.com Oct 10 '11 at 16:22

This question came from our site for professional and enthusiast programmers.

    
I can't work out what the question is. Your partitioning looks fine for a dual boot, except you don't need two swap partitions, as only one OS will be running at one time, so they can use the same swap. If you are happy to manage it yourself, a single boot partition is fine too - you only need one grub install and one grub.[cfg|lst]. If not, your boot can be in SUSE or FEDORA. What am I missing? –  Paul Oct 10 '11 at 23:11
    
When I ran openSuse Live DVD it halted scanning the hard disk for partitions saying sda3 is undefined, or something like that. I'll try to get the exact error later. –  Jaime Honrado Oct 10 '11 at 23:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.