Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just got my MacBook Pro back today from having the logic board replaced. While in the Apple store the Internet worked ok.

  • I got home and it was able to connect to my WiFi, but could not obtain an IP address. Instead it received a 169. IP address.

  • I was able to browse and check my modem on, but still had no Internet access.

  • I also tried entering a manual IP address, but still no Internet access.

  • I disabled WiFi and plugged directly into the modem via an Ethernet cable. Similar problem: no IP address.

  • I did a factory reset of the modem, so there are no MAC filters or anything enabled.

  • I think the MAC address of the AirPort module stayed the same since it is not on the logic board.

I have another MacBook Pro and an iPhone, and both can obtain an IP address and access the Internet from the same modem. I have tried an NVRAM/PRAM reset too.

It seems really weird that the one laptop cannot access the Internet and obtain an IP address. Even more confusing is that entering a manual address does not help!

share|improve this question
up vote 1 down vote accepted

Update to the issue: It had something to do with configd and mdnsresponder services. These two options briefly popped up while in the Apple Store and I was accessing the web there. When I returned home they disappeared and so did all network services.

To resolve the issue: I performed a Time Machine backup and upgraded to OS X Snow Leopard. After completing a restore from time machine the network went down again briefly and sorted itself out. I upgraded to OS X lion after that and all is good.

I searched more forums and noted similar issues with other people after having Logic Board upgrades from Apple.

share|improve this answer

To factor out the possibility that this is indeed a hardware issue (same WiFi module but mainboard new, not playing well together, but then why did it work in the store?) try booting from an OSX installation medium (I think the 10.6 installation CD includes Safari in the menu) or a Linux Live CD (i.e. Ubuntu) and see wether you can obtain an IP there. Also note down your MAC address, while you are in this other system environment, by issueing the command line ifconfig.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .