Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Two Windows XP SP 3 systems.

One recognizes and works with a General Electric 4-port externally powered USB hub.

The other gives a unrecognized USB device error. Tried in all ports.

What gives? Tried rebooting, etc, everything but reinstalling Windows. Is there any way to verify/reinstall the driver? It uses the Windows default driver (no 3rd party drivers required). Anything else to try?

share|improve this question
    
Have you tried plugging the hub into a different USB port on the second machine? It could be dodgy port. –  ChrisF Oct 11 '11 at 21:38
    
@ChrisF: Yes, actually tried every last port on it. –  Unsigned Oct 11 '11 at 23:36
    
Cleanup. when having a problem like this, it is actually preferable to not start plugging things into port after port. But to clean up the USB devices that are no longer there. A good way to Start on this problem is unhide everything, support.microsoft.com/kb/315539 , then unhide in the device manager, then start cleaning everything up in there that is ghosted, depending on how it looks , everything not just ghosted usb then rebooting. –  Psycogeek Oct 12 '11 at 2:04
    
@Psycogeek: Alright, completed those steps, deleted all the ghosted stuff. Rebooted and replugged. It went through the hardware detection again, showed up as an Unknown Device in the USB section, and threw the Not Recognized error again, like before. –  Unsigned Oct 13 '11 at 17:01
    
Next thing i can think of, is testing the power supply for the hub to see if there is power on it. you tested the hub in another machine next would be to check your USB drivers, for "version" of the sys and dll items. or to check if motherboard drivers are installed and up to date –  Psycogeek Oct 14 '11 at 2:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.