Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new iMac running OS X 10.5.6 and every time I change the time zone in Date and Time after I close it, it reverts to GMT.

This causes my email messages to appear with the wrong time.

Is there a fix for this? I have search online and a few people have the same problem without any answer.

Edit: I now realize that the timezone isn't even set. Closest city says GMT but Time Zone is empty.

share|improve this question
add comment

2 Answers

Is your user an administrator user?

Alternatively if all else fails you can run the following command that will remove the file that holds that preference (among others though) to allow you to reset it if the permissions on that file are not permitting you from setting it:

sudo rm /Library/Preferences/.GlobalPreferences.plist
share|improve this answer
    
I have already tried this. The file is recreated after restart but the problem persist. –  jvanderh Sep 3 '09 at 14:09
add comment
up vote 0 down vote accepted

Found the solution online here.

Here is a summary. The problem is that the configuration file has root permission only and deleting it to have it be recreated at reboot doesn't fix it.

From the link:

"The cause of the GMT timezone problem in Mac OS X In a nutshell the problem was being caused by /etc/localtime having the wrong permissions. It was pointing to the correct timezone, but the permissions were such that my user did not have access to the file.

At some point (I have no idea when) my default umask (the NSUmask) got changed from 18 (0x12 hex, 022 octal) to 63 (0x3f hex, 077 octal). This effectively means that, by default, files and links that get created will be read/write for the owner only.

Normally this shouldn't be a problem, but it can be when files created by one user on your machine need to be accessed by other users. In this case "System Preferences" was creating a new symbolic link (/etc/localtime) to the correct timezone file as user 'root' but the link didn't allow anyone (i.e. me) access to the linked to file, even though the permissions on the timezone file were fine.

Fixing the problem therefore is a simple three step process:

  1. Correct the default umask (NSUmask in this case)

  2. Logout and log back in

  3. Replace the timezone symbolic link"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.