Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have configured Eclipse to have Ctrl+Alt+U as a keyboard shortcut for synchronizing with SVN using the Subclipse plugin. However, when I select the project I want to synchronize in the Package Explorer, and press Ctrl+Alt+U, nothing much happens. If I instead right-click and choose Team and then Synchronize, as I have previously done, it works. I am running Eclipse on Kubuntu 11.04. There are no conflicting keyboard shortcuts in Eclipse or KHotkeys, as far as I can see.

I chose "In Windows" as the "When" condition for activating the shortcut, but I'm not exactly sure what this means.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You need to enable the SVN command groups for your perspective.

  1. "Window" > "Customize Perspective"
  2. Select the "Command Groups Availability"
  3. Check the SVN options from the "Available command groups" and click "OK"

You may also want to select "In Dialogs and Windows". Not sure if that is important but it works for me. Once you have these settings you can either use the shortcut from the Package Explorer to commit a folder/multiple files, or you can use the shortcut from the editor window to commit the current editor file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.