Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed RealVNC server (Windows), authentication mode was set to VNC password (there is no user name to fill).

When I tried to connect to server via the viewer, it asks for password and USERNAME. But there is no username configured on the server! I think I've enabled "Admin" check box in one of the options tabs. Could this be a reason?

What to do?

share|improve this question
    
Have you tried the server's local username? –  slhck Oct 12 '11 at 13:10
    
no! what do you mean server's local user name? username of the computer? –  shalom Oct 12 '11 at 13:20
    
because there is no username when i install and set up the vncserver –  shalom Oct 12 '11 at 13:57
    
I think I've enabled "Admin" check box i one of the options tabs of realvnc server, could this be a reason vnc viewer asks for a password? –  shalom Oct 12 '11 at 14:26
    
I don't know. Let's delete our other comments, it gets too cluttered otherwise. –  slhck Oct 12 '11 at 14:27
show 1 more comment

1 Answer

If you have set the server to VNC authentication and are being prompted for a username the chances are you have configured the extended VNC authentication for the Admin or ViewOnly account.

You can either leave the username blank and just enter your vnc password, or if you don't want the extended authentication, from the Server's options dialog, select the "Configure..." button next to VNC authentication and disable the Admin or ViewOnly account.

You may have also turned on guest access, that also prompts you for a username.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.