Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I edit any HTML file (e.g. Untitled.html) using TextEdit and save it, it saves a file named e.g. Untitled.txt automatically and removes the Untitled.html file. How can I prevent this from happening?

I followed these steps to setup HTML editing in TextEdit, but no use.

share|improve this question
    
What exactly are you trying to accomplish? You want to edit HTML files using WYSIWYG or do you want to edit the HTML code directly? –  Daniel Beck Oct 12 '11 at 18:25
    
I am trying to edit html directly –  reddyvaribabu Oct 12 '11 at 18:29
    
I can reproduce it on OS X Lion. This is really stupid... Seems like a genuine bug though, not much you can do except report it to Apple and hope for the best. –  Daniel Beck Oct 12 '11 at 18:31
    
yes mine is os x lion. How do we report to apple? –  reddyvaribabu Oct 12 '11 at 18:33
    

1 Answer 1

OS X 10.9 (Mavericks) appears to have a checkbox setting that would be helpful if selected:

TextEdit > Preferences > Open and Save

When Opening a File:

[checkbox] Display HTML files as HTML code instead of formatted text

(This is a later version than discussed earlier but could be helpful to others with similar or related problems.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.