Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I replaced the original hard drive within my Macbook Pro with a ssd to gain in speed. I kept my hard drive as an external hard disk mounted at /Volumes/Macintosh HD (got this name automatically, no choice from my side).

I've just installed the XCode 4.2 development files on this external hard disk, while the library and (maybe) documentation file did not give the chance to select the location.

The result of this is that if I invoke a xcodebuild -v it invokes the 4.2 xcode installation dir version of the command, calling the /Volumes/Macintosh HD/Library/Developer/usr/bin/xcodebuild command.

So far so good.

Today I started the installation of Django through the macports project. For some strange reasons it sometimes tries to use some stuff on the external disk, but the commands written in the automatic scripts do not use double quotes around filesystem locations, with the result of failing whenever it tries to address the Macintosh HD (with a space in its name) location.

Then I thought to change the mountpoint name, by giving the command

diskutil rename /Volumes/Macintosh\ HD Macintosh_HD

Its name got changed, I did a reboot but then it seems that all the previously failing scripts keep using the Macintosh HD old name, even if the new mountpoint is at Macintosh_HD.

My question is: is there any system-wide configuration file where these paths are written? How to solve this problem now?

share|improve this question
    
I wrote the xcode introduction because the django macports installation reaches a point in which invokes that command: if I keep the external drive DISconnected, all the procedure goes through up to the point in which it looks for the xcodebuild command. If the disk is not attached it fails. If the disk is attached, it fails at the very beginning due to the quotes reason. –  Antonio Oct 12 '11 at 22:57

1 Answer 1

I had a similar problem with my virtualenv during django development. Commands inside the virtualenv (e.g. pip) were failing because of the space in my filename/path.

Got it fixed with changing the name of my second HDD (where my home folder is located) to a name without spaces.

  1. Open /Volumes/ in Finder (use ⇧ + ⌘ + G if you don't find/see it)
  2. Open the information pane (⌘ + I)
  3. Change your HDD name under "Name & Extension". (Now some Applications like Dropbox start failing, because your home folder is moved.) Choose a name without spaces!
  4. Open System Preferences -> Users & Groups
  5. If locked, unlock the settings to make changes.
  6. Right click on the users effected by the change and open "Advanced Options..."
  7. Correct the path of the users home folder. Caution! Tripple check if everything is correct.
  8. Save changes. Reboot if asked.
  9. Fingers crossed.. Everything should work after you rebooted.

(Tested with Mac OSX 10.8 Mountain Lion.) Try at your own risk. Be sure to type in path and file names correctly!

After the changes your filename/path doesn't contain any spaces, so virtualenv in my case, maybe something else in your case, should work correctly even if it doesn't escape spaces.

Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.