Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have my xbox360 connected to my laptop-docking-station with a plain old network cable. The laptop itself is connected to my home network via wifi. Now i've set up the windows network so that the laptop is sharing it's internet connection over the lan port so the xbox can connect to the internet.

Everything is working fine for the first time :)

But when i switch off the xbox (which i sometimes do during working hours ;) ) and back on later that day - the connection cannot be used again until i restart windows. That looks odd to me. Am i missing some setting or is there any tool or command that i can use to re-initialize the shared connection so i don't have to reboot my machine?

share|improve this question
add comment

5 Answers 5

Have you tried disabling and re-enabling the network connection between the x-box and the laptop? That often works for me when I need to reset a network link.

Also, check the network card for the docking station (Under the network connection-->Properties-->Configure button), in the Advanced Tab, look for any power-related settings: the card may be being turned off to save power.

share|improve this answer
    
sry for the long delay - there's no power issue with the laptop network connection. there's at least some twitter client running all the time. i've tried de- and re-activating the connection, but it doesn't help :( –  BigBlackDog Aug 2 '09 at 16:12
1  
I thought you said the Xbox was connected directly to one interface, while you have another interface for the home network? If that's the case, the twitter client isn't going to keep the interface for the xbox up and running. Did you check the power settings for the xbox interface? –  romandas Aug 2 '09 at 21:58
add comment

I am almost 100% sure I have an answer that will work and is simple; I have a very similar setup to you and sometimes when I have difficulty getting the connection sharing to work I do the following:

  1. Right click on My Computer icon
  2. Go to Manage > Services and Applications > Services
  3. Find Windows Firewall/Internet Connection Sharing (ICS) in the list, right click on it and select Restart.

Wait a few minutes and you should be back in business.

share|improve this answer
    
thank you for taking the time and answer this question even if it's kind of old. I've changed the setup in the meantime and now the xbox has a cable connection to a switch. –  BigBlackDog May 20 '11 at 7:47
add comment

"the connection cannot be used again until i restart windows"

Can you be more specific? I assume the network shows as connected, but you cannot get internet. What's result of pinging google?

Try

ipconfig /release *
ipconfig /renew

Disclaimer; this will drop any connections you may have.

share|improve this answer
add comment

If you have an extra switch lying around? I would put one between your laptop and xbox and see if that helps any.

share|improve this answer
add comment

This method worked for me with my PS2.

Go to Run in the Start menu and typencpa.cpl. Select the wireless card that you are using and then hold Ctrl and click on the ethernet port that you will plug the XBOX into. Right-click one of your selected adapters and click Bridge Connections. Then, check if the connection works. If it does not work, run a command prompt as administrator. Type netsh bridge show a. Find your wireless card under the AdapterFriendlyName column and note the number next to it in the ID column. Then type netsh bridge set a <n> e and press enter. <n> is the ID number of the adapter. This enables force compatibility mode on the wireless card. If the connection still does not work try enabling force compatibility mode on the ethernet port. This can be done by changing <n> to the ID of your ethernet port. If it still does not work try disabling force compatibility mode on the wireless card by typing netsh bridge set a <n> d where <n> is the ID of the wireless card.

Note: You do not need to have internet connection sharing enabled for this to work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.