Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a wireless home network with 2 Windows 7 machines. I have created a homegroup which they are both part of. I shared the printer from the desktop and some files, and this all worked fine for many weeks. Recently printing from the laptop has stopped working. I shut down both machines overnight. The status of the desktop printer on the laptop is always shown as 'offline'. Printing works fine from the desktop. The desktop also can't see the laptop at all on the network. I've rebooted both machines. Both say they are connected to the homegroup and the password of the homegroup is the same. I have a McAfee firewall installed as part of factory settings.

Both the desktop and laptop have internet access through the network. Sharing and network discovery are on for both machines. It now looks as if the machines don't recognize each others homegroups. When I take the laptop out of the homegroup (intending to take it back in) it then recognizes no homegroup on the network.

EDIT: Disabling the McAfee firewall didn't help.

share|improve this question

2 Answers 2

Do you have sharing and network discovery enabled on the second machine? Can you ping each machine from the other? McAfee firewall may be causing the problem which is easy to diagnose by shutting it down and trying to view the desktop shares using \computername from the run command (aka the box in the windows start menu). If you can ping the workstation but can't reach it using \computername then look at your services and make sure that your server and your workstation services are running. They take care of a lot of sharing responsibilities on Windows.

share|improve this answer
    
Can't enable ping right now as the machines are in use. I'll have to get back to you. –  DJClayworth Oct 13 '11 at 3:46
    
What do you mean "Can't enable". Can't you just ping from command line. Try ping computername first, then try ping ipaddress if that doesn't work. They can point to different problems. –  Harold Larimer Oct 13 '11 at 3:48
    
If disabling McAfee didn't help then disable windows firewall next, although it shouldn't be causing a problem since you are in the same workgroup. You need to check the ip address and make sure that you are on the same subnet. You can do this using ipconfig from command line. You may have a DHCP problem. –  Harold Larimer Oct 13 '11 at 4:04
    
Thanks for your help. It turns out I have a router issue. When I rebooted the router I could reconnect the laptop to the homegroup and then everything worked fine. –  DJClayworth Oct 13 '11 at 4:23

It turns out that the solution to this was to cycle the router. At that point I could reconnect the laptop to the homegroup, and everything worked. I will test whether I needed to disconnect the laptop from the homegroup, or if just cycling the router would have done it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.