Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have both computers on Gigabit NIC, a router with gigabit ports.. and a Cat5 wire between them. When i transfer a file from the computer 1 to computer 2 i can't go further than 10-12 MBytes per seconds..

Edit: I am on Windows 7, i have a 1TB SATA3 disk 7200RPM and also a 7200RPM on laptop.


share|improve this question
Cat 5 can't do Gigabit reliably. Try Cat 5e. – Raphael R. Oct 13 '11 at 16:55
Please add more details: your OS (Windows, Linux?), make/model of the hardware, how do you do file transfers, etc. Also, try excluding the router, which often cannot support full gigabit speeds. Connect two computers directly with crossover cable and try again. – haimg Oct 13 '11 at 16:57
also accept some more answers, you have asked 7 questions and only considered 2 answers as correct ones... – woliveirajr Oct 13 '11 at 17:05
Sorry. My mistakes. – Rushino Oct 13 '11 at 17:41

My bet is that your cables are not Gigabit cables and so at least one of the network interfaces is running at 100Mbps. Not only is category 5 technically not capable of Gigabit speeds (though it usually works) but Gigabit cables require all 8 lines to be connected, not just 4 like fast Ethernet.

share|improve this answer

You should test your network throughput independently of the rest. Just perform a test via NetIO (platforms: OS/2 2.x, Windows, Linux and Unix) and you know if your problem is the network or not.

It is command line tool that is executed on both systems and it tests your maximum network throughput on raw TCP level.

share|improve this answer
What throughput i should expect on a gigabit network ? I think i will aslo try the crosscable. – Rushino Oct 13 '11 at 19:22
+1 for the tests. – Rushino Oct 14 '11 at 11:34

If your network isn't saturating then your machines are probably not fast enough somewhere else. Your machines' performance may be limited by the ability of your computers to read/write data to/from your disk. Try running something like HDTune to see how fast your HDD can write data.

Also consider copying the file(s) in question to your target machine and then try making a duplicate copy of the file(s) on the target HDD to test its real-world performance.

Also, try using robocopy <source> <target> /MT to copy the file using multiple threads.

share|improve this answer

Check that your HDDs and their controllers are fast enough. On both machines, run gstat and see if busy% is well below 100%.

This is a tip I got myself from voretaq7's answer to an almost similar question that I asked at

share|improve this answer
up vote 0 down vote accepted

I figured it out but that really strange...

I just changed the Speed of the gigabit NIC from Auto negotiation or auto detect to 1Gbps or 1000 and then it worked.. i get 120megs / sec of transfer rate.. but when ive set back to auto negotiation or auto detect on both NIC again.. (so i check if this was really the problem) it still worked at 120megs / sec.

How this is possible ?

share|improve this answer
Autodetect finds cat5 cable to be a little flaky and negotiates a lower rate? See if it does the same with cat5e or cat6. Also router? Is this a firewall/router and are the ports in it an ethernet hub or ethernet switch? I've seen autodetects push full duplex on a hub which can cause a fantastic error rate and slow data transmission from retries. – Fiasco Labs Oct 14 '11 at 3:25
I checked my setup.. and i figured out two things.. First i though i had changed both cable to Cat5e but i only changed one afterall the other one from the desktop to the router was still a Cat5 which can explain why this happened. Second, it may be the firewall.. but i am not too sure about this. However, i remember having accepted "network discovery" in win7 through.. maybe that did help ? I will perform more test tonight and come back with a clear answer.. but for now i think this is due to the Cat5 cable which seem to be able to maintain the gigabit speed but in an "unreliable" way. – Rushino Oct 14 '11 at 11:31
Forgot to mention something.. i also tried a crossover cable between my computer and my laptop directly.. and it was still 12megs / sec at that time. So the cable might not be the problem too. – Rushino Oct 14 '11 at 11:35
This can happen if a cable is marginal at Gigabit speeds or if the pairs are mapped incorrectly. (1-1 2-2 3-3 4-4 and so on instead of EIA568A or EIA568B) – David Schwartz Oct 18 '11 at 23:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .