Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It seems i can't install it even though the port djvu2pdf can be found using port search djvu:

$ sudo port install djvu2pdf
Warning: No port pkgconfig found in the index.
Warning: No port m4 found in the index.
Warning: No port p5.12-locale-gettext found in the index.
--->  Computing dependencies for help2man
Error: Dependency 'p5.12-locale-gettext' not found.
Error: Unable to upgrade port: 1
Error: Unable to execute port: upgrade ghostscript failed
To report a bug, see <http://guide.macports.org/#project.tickets>

[Edit]

Strangely, after doing a

$ sudo port sync

everything went back to normal.

share|improve this question
    
Have you tried sudo port selfupdate? – Daniel Beck Oct 13 '11 at 17:17
    
I did a sudo port sync and it then worked. Thanks! – Computist Oct 13 '11 at 18:36
up vote 1 down vote accepted

I had a similar issue with other package managers before.

Make sure you're up to date with the package information and the package manager itself. Use sudo port selfupdate to do this for MacPorts.

If you only want to update the package information, use sudo port sync.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .