Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed curl on a new ubuntu installation with apt-get and it behaves really weird.

When I do


everything work ok, but when I do

    curl -v

it fails with a connection timeout error:

    * About to connect() to port 80 (#0)
    * Connection time-out
    * Closing connection #0
    curl: (28) Connection time-out

curl -V shows:

    curl 7.21.3 (x86_64-pc-linux-gnu) libcurl/7.21.3 OpenSSL/0.9.8o
    zlib/ libidn/1.18
    Protocols: dict file ftp ftps gopher http https imap imaps ldap
    ldaps pop3 pop3s rtsp smtp smtps telnet tftp 
    Features: GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz

Any clue?

share|improve this question

migrated from Oct 14 '11 at 2:22

This question came from our site for professional and enthusiast programmers.

Works for me. Are you sure that your network connection has worked? – palacsint Oct 12 '11 at 10:40
It works without the -v, so I think it is ok. Also, WGET works fine. – plagelao Oct 12 '11 at 10:58
Other ideas: DNS problem, proxy, or a curl bug. Try with curl 7.22.0. – palacsint Oct 12 '11 at 11:24
Works for me, same versions as you've got. Does it still fail? – sarnold Oct 13 '11 at 23:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.