Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whatever language I select there are no syntax highlighting. Just the font color and background color are changing. In other editors there default syntax highlighting and they are pretty good.

Update showing selecting language does not make syntax highlighting:

selecting language

nothing happens after selecting python

the same code in Programmers Notebook with default highlighting

UPDATE

Here's what's happenning with style configurator as I commented to Sathya. Increasing font size increases line height:

enter image description here enter image description here

share|improve this question
1  
Are you opening files that have a file extension? If not, you should be able to select what language are using in a drop-down menu. –  Pubby Oct 14 '11 at 3:12
    
@Pubby8, I added images showing that selecting a language from the menu does not change the screen display. The last picture shows the same code in Programmers Notebook. –  Zeynel Oct 14 '11 at 4:14
add comment

1 Answer

up vote 1 down vote accepted

I can't simulate this - have you overridden the default syntax highlighting rules?

Head over to Settings -> Style Configurator and ensure that the syntax highlighting rules are present


I see what you're saying now - changing font setting for individual language does not seem to apply the font setting. Seems like a bug with Notepad++.

As a alternative, set the Global Font overrides as shown in the screenshot

Notepad++ global font settings

Font increased to 16

Font increased to 24

share|improve this answer
    
@Satya thanks I uninstalled the program and I will reinstall it and see what happens –  Zeynel Oct 14 '11 at 21:43
    
I installed it again. The logic of this Style Configurator does not make sense. I choose a theme as shown in your image; I select a language; then I change font size... and what happens? the line spacing between line increases but not the font size! I change the font but font is not changing. I gave up and I click cancel and the alert tells me that there are unsaved changes... I want to use Notepad++ but I cannot because of this issue. Style configurator just does not work for me. Can you help. Say I want to change font and font size in javascript what do I do? –  Zeynel Oct 30 '11 at 3:38
    
Updated @Zynel. Also , once you created a new file you'll have to select the language from Language -> J -> Javascript to apply the syntax highlighting rules. i.imgur.com/taDR6.jpg | i.imgur.com/TnODV.jpg | i.imgur.com/oxbdg.jpg. However, since we have a global override, it'll pick up font settings mentioned in the answer. If you're opening a saved file, this step isn't needed –  Sathya Oct 30 '11 at 5:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.