Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Imagine you have both computer with a NIC that do gigabit with a router that do gigabit. What can cause auto-negotiation to fail on network ? (with proof if possible)

share|improve this question
    
Are you sure both ends actually have autoneg enabled? Sometimes one is statically configured for gigabit, which disables autonegotiation. –  grawity Oct 14 '11 at 12:58
    
I am sure i have verified.. one are set to Auto detect.. the other one to auto nego. –  Rushino Oct 14 '11 at 12:59
add comment

2 Answers

up vote 4 down vote accepted

There are two possible reasons:

  1. Bad or incorrect (not CAT5e) cables or connectors, or cables that are either too short or too long according to the standard.

  2. Incompatible hardware. Here's what Wikipedia says:

    The first version of the autonegotiation specification, IEEE 802.3u, was open to different interpretations. Although most manufacturers implemented this standard in one way, some others, including network giant Cisco, implemented it in a different way. Autonegotiation between devices that implemented it differently failed.

    I don't believe there are any new devices that still use 802.3u, however crappy incompatible hardware is still common.

    802.3ab specified that copper gigabit Ethernet requires autonegotiation, if you can disable auto-negotiation and "force" gigabit connection in the settings, it most probably means that your hardware still uses the older, no-so-compatible standard.

    Clarification: Some network cards allow to set speed to 1Gbps. However, this does not disable auto-negotiation. According to IEEE Interpretation:

    Although operating speed is allowed to be manually selected by disabling Auto-Negotiation in Control Register 0, selecting 1000BASE-T mode of operation still requires that Auto-Negotiation be used. This can be accomplished by continuing to use Auto-Negotiation while limiting the advertising to 1000BASE-T capabilities.

    Essentially, network cards says "I will auto-negotiate, but I can do only 1Gbps, nothing else." This is not the same as just disabling auto-negotiation and setting speed & duplex manually.

share|improve this answer
    
Nice answer, but i can't agree with the last sentence. I have a recent motherboard and i can still set the speed if i would.. that doesnt mean it use the older standard since its a very recent motherboard with a gigabit port. –  Rushino Oct 14 '11 at 15:08
1  
I added clarification about my claim about auto-negotiation. Unfortunately, NIC config GUIs are often too vague about what they actually do/change. –  haimg Oct 14 '11 at 15:36
    
You actually saying that setting the speed to 1 Gbps actually doesn't disable Auto-negotiation ? –  Rushino Oct 14 '11 at 16:09
1  
Yes. Auto-neg is mandatory for 1Gbps per 802.3ab. –  haimg Oct 14 '11 at 16:15
1  
Alright, alway nice to know. Ive heard that changing the speed can actually disable auto-neg. But i might be wrong. Anyway i guess we shouldnt be changing thoses settings. I will check my network tonight and post an update. Thanks for your help. –  Rushino Oct 14 '11 at 16:36
add comment

Dodgy cables: I've just replaced a 3m patch lead to a laptop docking station that was causing problems - the gigabit connection was either working, very slow or connecting (and not working) at 100 or 10Mbit

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.