Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am dual booting Windows and Ubuntu. I haven't started the Ubuntu for a long time and 1 hour ago I decided to get back to it.

So I started Ubuntu normally, saw the "update window" pop-up and I decided to do the update. After a long hour of updating now when I start the Ubuntu I get to the loading Ubuntu logo with the purple background and nothing happens.

Any suggestions?

share|improve this question

migrated from Oct 14 '11 at 20:59

This question came from our site for professional and enthusiast programmers.

I apologize, but I laugh so hard.. – karlphillip Oct 14 '11 at 20:54
Why did we move this from SO To SU instead of to the Unix or Ubuntu sites? – mathepic Oct 14 '11 at 21:01
@mathepic Because it's on-topic here too? – slhck Oct 14 '11 at 21:49
@slhck but the others would be a more-specific, nicer spot for it. – mathepic Oct 14 '11 at 21:57
up vote 0 down vote accepted

Had you updated your 11.04 before upgrading the system to 11.10. I guess that too might be the problem. simple solution for this is use usb image to boot from usb and install( check for your hardware compatibility). Don't forget to back up your data using live image. You can recover a GNU/Linux system, but, it will be tricky thing. just go for the simplest and easiest solution. This is only my suggestion. I am not an linux expert. I am just an end user of linux.

share|improve this answer

It seems to be a common problem with some graphic cards.

Take a look here:

Hope it helps.

I personally repaired it by upgrading using the Ubuntu 11.10 Live-CD on a USB stick. The problem is that it didn't even boot the GUI due to my graphic card. So I had to follow the following procedure writen by prince_of_death:

Step 1: boot from the live usb and as soon as it displays the ubuntu color screen press 'F6'. this will take u to a boot option page where a pop up bar will appear due to F6 being presses. press 'Esc' key and go up to "try Ubuntu Without Installing" and edit the kernel string to add "poulsbo.asd=1 psb_gfx.asd=1" to the end then press enter.

Step 2: the live usb will then boot to the desktop GUI where you can start the installation.

(I selected here the second option "Upgrade from 11.10 to 11.10")

Step 3: after installation reboot your system and at the GRUB menu press 'e' to edit the first kernel. (this is needed or it wouldn't boot to the desktop GUI)

Step 4: modify the kernel string after 'quiet splash' and add "poulsbo.asd=1 psb_gfx.asd=1" then press 'F10' to boot with the modified kernel

Step 5: it will now boot to the desktop GUI were you will now install the EMGD driver with :-
sudo add-apt-repository ppa:gma500/emgd-1.8
sudo apt-get update
sudo apt-get install xorg-emgd emgd-dkms
sudo emgd-xorg-conf
(once the EMGD driver is installed you no longer need to edit the kernel at boot)

Step 6: this step might also be needed to prevent session from not being started.
sudo mv /etc/init/plymouth.conf /etc/init/plyouth.conf.disabled
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .