Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running into issues while attempting to install 32-bit Google Chrome on Ubuntu 11.10 64-bit. I have my reasons for doing so, though they're rather complex. I'd like to know how to resolve the issues that I'm running into.

So far, I've downloaded the 32-bit .deb package from, then attempted to install it using the following command:

sudo dpkg -i --force-architecture google-chrome-stable_current_i386.deb

Upon running that, I'm getting the following output:

Selecting previously deselected package google-chrome-stable:i386.
(Reading database ... 159727 files and directories currently installed.)
Unpacking google-chrome-stable:i386 (from google-chrome-stable_current_i386.deb) ...
dpkg: dependency problems prevent configuration of google-chrome-stable:i386:
 google-chrome-stable:i386 depends on libbz2-1.0.
 google-chrome-stable:i386 depends on libgconf2-4 (>= 2.27.0).
 google-chrome-stable:i386 depends on lsb-base (>= 3.2).
 google-chrome-stable:i386 depends on xdg-utils (>= 1.0.2).
dpkg: error processing google-chrome-stable:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for man-db ...
Errors were encountered while processing:

I've double-checked, and libbz2-1.0, libgconf2-4, lsb-base, and xdg-utils are all already installed. In my attempts to search on Google to try to resolve the issue, I've also installed ia32-libs.

Any other ideas? What am I missing?

share|improve this question
up vote 3 down vote accepted

Chrome is looking for the 32-bit versions of libraries, which are not available in the repositories you have configured. Unfortunately, there is not really a good solution to this, since you will need to have two different versions of many libraries installed. For now, you can try just using the ia32-libs package as discussed here. Things to look in to are MultiArch, which is a new Ubuntu feature that appears to be mostly implemented. A little discussion of this issue can be found here.

Edit: as of 2012, MultiArch support in Ubuntu is very good. Users will typically not encounter this type of error any more.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .