Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a linux box at home. I know I can set up a proxy on a current computer by opening up terminal and typing ssh -D PORT USER@SERVER and then enter in the proxy and port in a browser. HOWEVER - I do not have Terminal permissions my current computer.

I have DynDNS set up, and port forwards to my linux box. I logged in remotely and then set up a SOCKS proxy to another computer.

Setup like this:

HOMECOMPUTER$ ssh -D 8080 USER2@OTHERSERVER
OTHERSERVER$

I should be able to enter HOMECOMPUTER dyndns url as the SOCKS server and 8080 as the port, correct?

It doesn't work; pages don't load. What's wrong?

If this question wasn't clear enough, sorry :( I'll change it if necessary.

share|improve this question

migrated from stackoverflow.com Oct 15 '11 at 7:50

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 3 down vote accepted

If a bind_address is not provided with the -D option, then the default is to bind only to localhost. You can have the SOCKS server listen on all interfaces by binding it to the IP address 0.0.0.0:

ssh -D 0.0.0.0:8080 user2@serverB

You should then be able to enter HOMECOMPUTER dyndns as the SOCKS server and 8080 as the port.

share|improve this answer
    
where 1.2.3.4 is 0.0.0.0? –  tekknolagi Oct 19 '11 at 3:54
    
yeah buddayyy this works! enjoy the rep! –  tekknolagi Oct 19 '11 at 4:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.