Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just got my first Mac and some things are not very obvious to me.

Is there a way to stop it dimming the screen while on battery power when I'm on a Skype call or watching things on YouTube?

I don't want to completely turn off this behavior; I'm just curious if OS X can detect if my computer is in use beyond keyboard and mouse input.

share|improve this question
add comment

2 Answers

up vote 7 down vote accepted

Generally deactivating dimming

Do you generally want to disable this option? Under System Preferences » Energy Saving, you can disable the auto-dim for battery. Might look different in Lion.

enter image description here

In YouTube, watching videos on full-screen will not trigger the display sleep. I can imagine the same goes for full-screen Skype.

Temporarily deactivating dimming

If you only want to deactivate it temporarily, you can do so by using the Hot Corners feature.

  • OS X 10.6: System Preferences » Exposé and Spaces » Exposé » Active Screen Corners
  • OS X 10.7: System Preferences » Mission Control » Hot Corners

enter image description here

The trick now is to have a hot corner for deactivating the screen saver – yes, even if it's not running at the moment. Now, when you are using Skype or watching YouTube, just move your cursor in this hot corner. It will prevent the display from sleeping. When you're done watching or using Skype, move the cursor out of the corner again.

share|improve this answer
    
Hot corners seem to be a good solution to this. In OS X lion you can set it up by going to system preferences -> mission control -> Hot corners. Thanks again. :) –  Kit Sunde Oct 15 '11 at 9:34
    
Thanks, I added it to my answer in case somebody's confused! –  slhck Oct 15 '11 at 9:43
add comment

This has (most likely) nothing to do with YouTube or Skype; your Mac dims the display because you're not using the mouse or keyboard and you're on battery power.

You can deactivate this behavior by opening "System Preferences", selecting "Energy Saver" and unchecking "Automatically reduce brightness before display goes to sleep"

Energy settings

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.