Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use my friend's USB flash drive (Corsair flash voyager 16gb) to transfer files from my laptop to my desktop computer.

However, since a couple of days my laptop stopped recognizing the USB key.. while there is still no problems with all other computers.

I use Windows 7 64 bits if that can help.

I tried uninstalling the driver, rebooting and all those kind of tricks, but it won't work.

When I connect it and open the "My computer" window, I see "Removable Disk (G:)" for a moment, then it disappears... then it reappears again and it keeps doing that periodically. I can't even right click then hit "Properties" because it disappears.

As I recall, it DOES work on every other computers, I think it has to do with the driver but what can I do?

share|improve this question
    
You might have power issues with your computer, but please check first if you have Laptop's BiOS Update from the manufacturer website, most of the times it fixes those issues. –  Miro co Oct 15 '11 at 21:08
    
If your laptop has more than one USB port, try in a different one. Seems like a loose connector to me. –  haimg Oct 15 '11 at 21:24
    
I tried on every USB port possible, it wouldn't change a thing. Also, other USB devices (like mice) are working normally. I will try to do every windows update possible, as well with my "Vaio care center" to see if there are more sony updates available. No offense but I don't think it'll work (but I sure do hope it would!) –  dominicbri7 Oct 15 '11 at 22:03

3 Answers 3

up vote 2 down vote accepted

I had the same and solved this by:

  • downloading the 64 bit USBDeview
  • run as administrator and removed all occurrences of my USB (you'll need to know its Device Description)
  • plug in the USB; possibly in an other port to force Windows to reinitialise it

This worked for me!

share|improve this answer

Try plugging your laptop in if you haven't already while using it. I regularly see issues with external HDD's failing to be recognized when the laptop is on battery power. Maybe the same issue is happening with your USB stick.

share|improve this answer
    
Hmm I didn't think of that, I'll try next time I get my hands on that same USB drive –  dominicbri7 Nov 23 '11 at 23:20

Plug your USB device, go to control panel, then click Hardware and Sound. Under devices and printers, select Device Manager. There will be a pop up window.

Scroll down to Universal Serial bus Controllers and click on it. You will see USB Mass Storage Device. If there is a yellow warning by its side, that means you have to update the driver. Right click and select Update Driver. Before updating you have to be connected to the internet or put in a CD that contains your Windows driver and then update it so that the yellow warning will clear.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.