Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I noticed that a few things are running slow today on my Windows 7 laptop. Specifically, they are:

  • Opening and closing windows takes several seconds for the animation to complete.
  • Windows media player opens fine, but the movies are very laggy
  • MMORPG's, such as RuneScape, are extremely laggy
  • When waking my computer from sleep mode, after entering my password, my desktop takes about 3 seconds to fade in

Other than those, everything runs at a normal speed.

Things I've done that maybe contributed to this problem:

  • Changed the graphics processor (by plugging in/unplugging the charger) [however, no matter how I change the graphics, I'm still getting this lagginess]
  • Installed AdBlock, a Firefox addon [I recently removed it, and I'm still experiencing this problem]
  • Went into Advanced System Settings, Clicked Settings, and unchecked a few visual things (such as the animation for opening and closing windows) [sure, this got rid of the opening/closing windows lag, but I like that little animation - plus that leaves all the other lag problems I'm experiencing]

So, does anyone have any ideas/fixes? If so, please respond. Thank you.


Some Other Information:

  • I'm on a HP Pavillion dv7 laptop, 4285 Entertainment PC, with: intel CORE i5 inside, ATI Mobility Radeon Premium Graphics, Microsoft DirectX11
  • Opening and closing of windows: Defined as opening a program (i.e. Firefox) or closing it by hitting the X in the upper-right hand corner. Lately, the animation for opening and closing windows (which is simply either growing from the icon from the taskbar to fill the screen, or shrinking from the screen down towards the icon on the toolbar.) This problem also occurs for minimizing/maximizing windows.
  • Very laggy movies: defined as .avi movie files saved to My Documents which skips several frames per second and seemingly slows down the movie as a whole
  • Extremely laggy games: I tried playing an MMORPG today, and movement in the game was at least 10x slower than it ever has been, even when playing on the lowest detail/graphics
  • Desktop taking 3 seconds to fade in after sleep: in this scenario, I had no other programs running visibly. The computer generally fades to black from the password screen to the desktop in about 1 second, normally. However, it is now taking 3 or more seconds.
share|improve this question
1  
I've re-tagged your question, and yes, this is the right place for your question –  DragonLord Oct 15 '11 at 22:04
    
Ok thank you. I have taken those parts out of the question now. –  Mike Gates Oct 15 '11 at 22:06
    
@MikeGates For the most part turning some things off in the settings should speed things up. Tell us more about what you did with the graphics processor. Is this a laptop? –  TMB Oct 15 '11 at 22:09
    
@TMB: This is a laptop, as implied by the existence of a charger: Changed the graphics processor (by plugging in/unplugging the charger)... –  DragonLord Oct 15 '11 at 22:13
1  
Have you checked you Widnows' Task Mananger to look for busy processes? Have you checked Windows' Performance Monitor to see if it reports any potential bottlenecks? Have you examined your Windows Event Logs to see if there are any reports of errors? Have you tried a System Restore to a point in time when it was OK? How does it perform in Safe Mode? Have you used MSConfig to temporarily disable startup programs and services to see if that has any effect? –  techie007 Oct 16 '11 at 2:50
show 8 more comments

4 Answers

The best way to access these situations are to provide more information.

The specs of your computer helps along with make and model

Opening and closing of windows is very vague. Opening Visual Studios generally can take up to 30 seconds, which is normal. Outlook also takes a good amount of time. . .

Very laggy movies generally mean very little. Is this a DVD or a file on your harddrive?

Extremely laggy games? When goes it get laggy? How laggy is it(use Fraps to get a benchmark)?I know WoW, even with the most powerful super computers, is brought to its knees as you enter Ironforge.

Your desktop takes 3 seconds to fade in after sleep? How many programs do you have open? What programs do you have installed? For all we know, you are running chkdsk in the background. . .

share|improve this answer
    
The answer to all of your questions are edited to the bottom of my question, under the title "Some Other Information". If you need more information, just ask. If the information would be difficult for a novice to retrieve, a description on how to access the information you want would be appreciated. –  Mike Gates Oct 16 '11 at 1:33
add comment
up vote 2 down vote accepted

I received this answer on a different forum, and now my laptop is running perfectly again


OK, before doing anything, I suggest updating your Windows. Go to Control Panel > System and Security > Windows Updates > install everything you can and restart your PC.

Also, update your Graphics Drivers (when you don't have a video driver, everything works a little slow, you can check it out by opening the browser you are using and slide it over your desktop from left to right. If it slides in frames then probably is your video driver). To update your graphics go to Start > type Run > type in Run DxDiag > and search for your video card manufacturer on the Display tab > go to Google and search for your manufacturer (I.E: ATI/Nvidia drivers).

Go to their official website and get the latest drivers available for your Graphics Card > install it > restart your PC.

Also, update your DirectX, link bellow:

http://www.microsoft.com/download/en/details.aspx?id=35


Thank you to Mod Paul Z.

share|improve this answer
    
Glad that worked out. –  surfasb Oct 16 '11 at 12:19
add comment

I had a similar problem. I'm using a Sony Vaio E Series laptop. My specs are:

  • Windows 7 Home Premium -64 bit
  • Intel Core i3 M 370 processor
  • 4 GB RAM
  • ATI radeon 500GB graphics card

My problem was this: I had a slow working graphics (minimizing & maximizing windows, all games where running slow etc). But there was NO ISSUE with the computer's other performance like copying files, web browsing etc. And this slow-graphics problem would kick start randomly, like say, never for 3 days, every time you boot after shutting down in the same day. And the problem always got corrected after a restart.

Then, what I noticed was, when I do my booting (not restarting, the first boot after you shut down, for example in the morning :D) after disconnecting all USB devices (ext hard disks, cooling pads, usb modems etc.) there was NO graphics lag at all and this is what i am doing now.

share|improve this answer
add comment

Earlier this week I noticed my computer doing all the same things listed above. When watching something on small player last night I noticed that my background display changed, as I had it programmed to change through the themes provided by Windows.

I changed my background to "Windows basic", blue with the Windows symbol.

Everything fixed itself and I have no issues now. I think it's something in Windows slowing the change of the background images.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.