Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason when I boot my laptop now (winxp), it doesn't start explorer.exe automatically; I'm left with a desktop background and a mouse pointer. I have to run taskman and start explorer.exe manually.

Recently I had Spyware Dr. detect a severe threat, and I was wondering if there was anyway to re-hookup explorer.exe on startup.

share|improve this question
    
It sometimes does that on my laptop too. Have no idea why but sometimes it boots ok and sometimes I have to run it myself. Maybe I'm not patient enough and it will start it but I can't wait more than 15 minutes for that :) –  vava Sep 3 '09 at 8:15
add comment

8 Answers

up vote 2 down vote accepted
  1. Click start
  2. Click Run
  3. Type "cmd" then hit enter
  4. Type "sfc /scannow"

Note: U will need ur XP installation CD

share|improve this answer
    
I only have a restore CD, will this matter? –  leeand00 Sep 4 '09 at 13:18
    
Yes because the restore CD has Recovery tools not the installation files. –  Chris Tarazi Sep 4 '09 at 18:06
    
@baseballboy64116 it's asking me for a Windows XP SP3 CD. I don't have one of those. Mine is like SP2 or SP1. I downloaded all of those updates off the Internet. –  leeand00 Sep 8 '09 at 14:48
    
If u hagve acess to another compuiter u will need to slipstream the SP)3 update. So please download it and use this tool to slipstream ur disk. home.midmaine.com/~nlite/nlite/nLite-1.4.9.1.installer.exe –  Chris Tarazi Sep 8 '09 at 23:25
    
@baseballboy64116 I tried this but it was to fix a different problem (actually the fix worked on that problem! :) ) Additionally, I was required to download the Windows SP3 CD to fix the problem. –  leeand00 Dec 12 '09 at 16:30
add comment

Check that it hasn't been disabled to run at logon with Autoruns:

alt text

share|improve this answer
    
@Matthew Lock, yeah mine looks just like yours...does the system rewrite that registry key when you run explorer.exe? –  leeand00 Sep 3 '09 at 22:15
add comment

That is a strong indication of malware on your system!
While that may not necessarily be the problem, its something to think about first.

Here is one discussion thread and another older one.

Check

  1. Can your start it manually or is the executable itself missing
  2. What is registered at the Winlogin Shell key (referred in another answer here)
share|improve this answer
    
He mentioned that he can start it manually with Task Manager. –  Sasha Chedygov Sep 3 '09 at 4:02
    
@musicfreak, good point, I missed that. So, we need to know whats connected to the Shell key. That would indicate past window-manager installations or malware association attempts (that seem to have failed). –  nik Sep 3 '09 at 4:11
    
@nik I'm assuming that the Shell key is in the registry? What is the path to it and how do I check it? –  leeand00 Sep 3 '09 at 22:10
    
@nik Oh wait @Matthew Lock has that in his answer...right? –  leeand00 Sep 3 '09 at 22:13
    
@leeand00, scoopdreams has it in his answer too. –  nik Sep 4 '09 at 2:58
add comment

You can try these steps to get explorer.exe to start with logon again :

  1. open up Registry Editor (regedit.exe)
  2. go to HKEY_LOCAL_MACHINE/SOFTWARE/MICROSOFT/WINDOWS NT/CURRENT VERSION/WINLOGON
  3. find the "Shell" key and replace whatever value you find down there with explorer.exe

Hope this helps!

share|improve this answer
1  
You may wish to check all of the registry values related to system startup. bleepingcomputer.com/tutorials/tutorial44.html –  greyDrifter Sep 3 '09 at 4:02
    
the WinLogon/Shell one is the most common attack target for malware. check that one first, then the rest as greyDrifter has suggested. –  caliban Sep 3 '09 at 4:07
add comment

i created a new ADMIN account. transferred my documents from old account to new one. then deleted the old admin account. everything is perfect now

share|improve this answer
add comment

Can you create an entry in the startup list? In start, all programs, startup. Just create a new shortcut to explorer.exe (good luck tracking down the path). Works on Vista, maybe xp.

Not a solution I know, but a fairly easy workaround.

share|improve this answer
add comment

I found this:

http://en.kioskea.net/forum/affich-26897-all-my-task-bar-desktop-icons-missing#8

I may try this later (backing up my explorer.exe first of course...(and the rest of those files...))

share|improve this answer
add comment

I have seen this a few times now, the majority caused by pesky malware.

Try performing a system restore back to when your computer was working okay.

It will simply roll back the registry and system files to a particular date.

  1. Log on as Administrator (or a user with local administrator rights)
  2. Click Start > All Programs > Accessories > System Tools > System Restore
  3. Select Restore my computer to an earlier time and click Next
  4. Select the most recent system restore point from the list and click Next
  5. Click OK
  6. Click Next

Give that a go.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.