Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running arch linux, latest stable with gnome3 and gdm, I have a US keyboard (notebook). I am using the default layout except that I used xkeybdmap to bind the right alt key to alt gr to get special characters.

All was working well until today I did something, and I'm not exactly sure what, and I just noticed that neither of the alt keys do anything, for example I can't switch windows in irssi, alt gr doesn't modify anything, ctrl+alt+directional keys don't change workspaces, alt + F10 doesn't m{ax,in}imize the window, etc.

I know this is only in X because I can still change TTYs with ctrl+alt+[0-9], and alt keys work in other ttys (except for the alt gr functionality of course, because I did it with xkeybdmap)

Things I did recently was changing urxvt settings (.Xdefaults) to change my $TERM to rxvt-256color but that shouldn't affect anything afaik. I also installed tmux, but that affecting it doesn't make sense either. But the thing I think triggered it was that I accidentally pressed ctrl+alt+F11, and before doing that I know that the alts still worked.

Any idea what happened and how to fix it? I like my alt keys... Thanks!

EDIT: actually the command I was talking about was setxkbmap -option compose:ralt, and as I was asking this I realized that I could try that ctrl+alt+F11 again, and magically enough that fixed the alt keys, although I had to redo setxkbmap -option compose:ralt. Can anyone explain what's happening here?

EDIT2: And to clarify further, I changed back to my default GUI TTY after accidentally pressing that key combination from hell. I also tried rebooting, and that didn't work either (it's not windows, heh)

EDIT3: Alt keys still not working in irssi, what's up with that?

share|improve this question

While Googling for an answer to the exact same set of symptoms, I found your problem a long time after your question. I figured it out as result of what you wrote, so thought I should put my answer up ... mainly for me, but also in the event you were still curious about the problem.

Although I hadn't used setxkbmap in the same way - I had used it to change to dvorak. In tweaking around with X to get Dvorak, no-caps lock etc, I edited .Xdefaults and removed:

XTerm*eightBitInput: false

XTerm*metaSendsEscape: true

After adding these back into .Xdefaults ( or maybe it wasn't there to begin with? ) everything was happy again. I'm pretty sure metaSendsEscape wasn't present initially, but that eightBitInput was, so perhaps that is the only entry needed.

Remember: Xdefaults case is usually important.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .