Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Mine is a Dell Inspiron 1564 installed with Windows 7 basic (64 bit).

For over a year it was working fine. But now whenever I try to turn it on, it just keeps on waiting on the Dell startup screen (the blue progress bar is fully loaded).

Today I even formatted my hard drive and re-installed Windows(partitions exist as they were, only C drive formatted) to see if it was a Windows issue but I still face the same problem.

The bootup proceeds only after I press the F8 button, till then nothing happens. After pressing the F8 button, it starts up and works perfectly fine.

Please provide some insights into this, it will be really helpful.

Edit: When I run Dell diagnostic tools, it does not find any errors now. After the restart, the system boots up normally (I.e. without pressing any key) for a couple of time and then returns back to original problem.

As per Dell website, Re seating the RAM and hard drive can help resolve this issue but in my case it did not help. Any clues?

share|improve this question
Re-seat your memory modules, it this does not help test your memory modules one at a time using – Moab Oct 17 '11 at 2:37
The memtest in dell diagnostics did not reveal anything. I ran the complete test but it showed everything was fine. – Raghav Bali Oct 17 '11 at 7:53
Starting to sound like something is corrupt in the Master Boot Record. – Moab Oct 17 '11 at 15:24
Can you suggest any reliable tool to fix MBR? – Raghav Bali Oct 19 '11 at 4:47
Problem is Dell uses a custom MBR, so if you use the fixmbr command to repair it this will break some of the custom Dell features such as the recovery partition. Dell does not provide a way to repair the custom MBR other than to perform a complete OS recovery. – Moab Oct 20 '11 at 3:41
up vote 1 down vote accepted

Finally the issue is fixed. As per @Moab's suggestion, i reseated the RAM and the HDD and reformated the HDD (removed all the partitions). After a fresh OS install it still did not workout.

The issue turned out to be due to power supply, the plug point to which the power adapter was attached had loose earthing, when i turn on my laptop without the power cord, it works perfectly fine. I guess the Earthing was the problem.

share|improve this answer

Go into bios and disable Dell Screen (not sure what the name is for Dell Inspiron) that is hiding relevant information that may be hidden under the Dell Screen. Most likely it hangs with some question that Dell Screen covers that F8 button goes thru.

share|improve this answer
I also thought the same, just that I was thinking that Windows loader might be waiting on something but the re-install proved I was wrong. I will try and search for disabling the dell load screen. Thanks – Raghav Bali Oct 17 '11 at 7:55

Usually Dell laptops come with a Windows 7 recovery disk. If you are using that one, you should be fine.

Other Dell laptops come with a hidden OEM recovery partition (which is the best way to restore the OS). If you still have problems, contact Dell Support.

share|improve this answer
He does say - "Today i even formatted my hard drive and re-installed windows(partitions exist as they were, only C drive formatted) to see if it was a windows issue but i still face the same problem." – Joe Taylor Oct 16 '11 at 19:57
Won't the factory setting reset clean up my partitions? I have a lot of data in other drives/partitions and i cannot afford to remove my partitions – Raghav Bali Oct 17 '11 at 7:54
Using Windows Recovery partition or alike won't solve this problem if you reinstalled machine and the problem still exists. Find the right settings in bios first. If you can't see what's the problem there's no sense to start doing more. – MadBoy Oct 17 '11 at 12:06
@MadBoy What settings are you referring to? I could not find any specific one for which the system is waiting (till F8 is pressed) – Raghav Bali Oct 18 '11 at 10:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .