Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

BIOS displays the following two lines upon hard reboot (i.e., cold reboot, cold boot, or cold start):

The following configuration options were automatically updated:
CD-ROM: HL-DT-ST R/W/DVD GCC-4481B
No IDE Fixed Disk Present
F1: Save Changes

After selecting F1, the system soft reboots (i.e., warm reboots), then displays the following:

The following configuration options were automatically updated:
Disk: 40.0 GB MAXTOR 6E040L0
CD-ROM: HL-DT-ST R/W/DVD GCC-4481B
If you are running UNIX you need to configure your system using the computer setup utility f10
F1: Save Changes

After selecting F1, the system soft reboots again.

This time, Microsoft Windows XP loads successfully without any BIOS errors.

So, my client discovered a work-around, but how may I correct this issue so the system hard boots and identifies the hard drive?

HP Compaq dc5000 Microtower PC (2004) running Microsoft Windows XP, 2.5GB RAM, 3.0GHz processor.

share|improve this question
1  
I dont know if it helps, but after solidifying an IDE setup (not Sata) We would go into the IDE section of the bios and switch each drive off of auto, to "lock the disk in" that was recognised. that saved 2miliseconds :-) from the system having to re-recognise it each reboot. Any time we Changed anything that had to be set back. We would also do this for the Cd-rom item. I have no idea if that would stop this problem. Also i wonder if the Time allowed for recognition of drives might be set to short, and effecting it somehow. I have never had that change recognition though, even at 0. –  Psycogeek Oct 17 '11 at 9:07
1  
Other things like this but not the same happend with some people when using CS (cable select) or Not cable select, depending on what the hardware preferred. and If the Drive has that jumper for Master-NoSlave , not just master and slave. that was also a point of confusion, that varied depending on the hardware. and all of it will depend on what switches you have to work with. –  Psycogeek Oct 17 '11 at 9:13
2  
Might also check the CMOS battery. –  Justin Pearce Oct 17 '11 at 15:49
add comment

1 Answer

up vote 0 down vote accepted

I discovered two solutions to this issue:

  1. Enter BIOS Setup (F10), then select "Advanced (advanced users only)" > "Power On Options" and set option "Enable/disable POST delay (for slow hard drives)" to five seconds

  2. Enter BIOS Setup (F10), then select "Advanced (advanced users only)" > "Power On Options" and change option "Select POST Mode" from QuickBoot to FullBoot

Root cause: the BIOS seems to execute POST before the hard drive becomes recognizable to the system.

The former case (POST delay of five seconds) seems like the best option, since FullBoot seems to take several minutes to check the RAM.

share|improve this answer
    
A third option exists: purchase a better hard drive. ;o) –  schultkl Oct 20 '11 at 17:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.