Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Trying to view some local html/css/js files in a mobile browser on my iOS device. Thought maybe file-sharing would be an option, and is, but I'm not completely satisfied with it. Any time I try to do the following an error occurs. Web sharing is on and available at http://192.168.1.101/~user but I have to manually copy the files in.

If I try to symlink a folder in so that the address could be viewed at ''~user/some_dir by issuing

$ ln -s /Users/user/dev/some_dir ~/Sites/

then I get a 403 forbidden error. I've tried to remedy this by modifying a user.conf file in /private/etc/apache2/ and using the following syntax:

    <Directory "/Users/user/Sites/">
        Options Indexes MultiViews SymLinks
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>

but nope, still doesn't work. I get a 403 error. If I try to symlink each individual file in instead of using a directory as a sub-directory, same error.

Any help would be greatly appreciated! I'd just like to symlink directories into the ~/Sites one and browse them on my iOS device over wifi. I'm on OS X 10.7 Lion trying to connect with iOS 5.

share|improve this question

migrated from stackoverflow.com Oct 17 '11 at 6:08

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer

answer for Snow Leopard, 10.6.8:

the default user config found in /private/etc/apache2/users/<username>.conf is

<Directory "/Users/<username>/Sites/">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

add FollowSymLinks to the Options, restart apache and you should be fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.