Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When copying multiple (>100) files from my Windows 7 x64 machine to a remote system the copy action becomes really slow when it needs to overwrite files. If I copy to an empty folder it is as fast as I would expect, but when copying to a folder and overwrting it becomes very slow. For example 300 files (about 4MB) takes then almost half an hour.

I already tried already the following:

  • Disable Remote Differential Compression
  • disabled the automatic adjustment for the TCP window size (netsh interface tcp set global autotuninglevel=disabled)
  • Use TeraCopy

But it doesn't solve the problem. It is still very slow when overwriting files. The same action on a XP-machine takes only about 30 seconds to complete.

share|improve this question
    
What are the specs of the target system? –  surfasb Oct 17 '11 at 10:33
    
HP Proliant server with Intel Xeon E5405 (2Ghz) processor. 4GB Ram. CPU usages around 5%, Memory usage around 1.5GB, Network usage around 5%. –  Patrick Lind Oct 18 '11 at 12:02
    
it is Server 2003 R2 –  Patrick Lind Oct 19 '11 at 6:32
    
Try to add QoS packet scheduler into Network Adapter properties. –  user104902 Nov 10 '11 at 17:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.