Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My 32 bit Debian Etch with Etch-n-Half kernel 2.6.24 and Etch-n-half video driver xserver-xorg-video-intel 2.2.1-1~etchnhalf2 does not recognize my on-board LAN and Video.

I can work only with VESA display. And additional PCI LAN card (that I wanted to use for Cross-X-Cabel).

output of lspci

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
04:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10

According to MB Spec:

Video: Intel G41 Express Chipset Graphics and Memory Controller Hub Graphics (GMCH)
LAN: Realtek 8111D Gigabit Ethernet Controller LAN Support

When I run dpkg-reconfigure xserver-xorg is suggest i810 driver but X does not start, it does not start with intel driver as well; only vesa.

LAN I even can't find in lspci... the last Realtek card is external one 100MB card.

Where to start from?

share|improve this question
please post your latest x-org logs for us to troubleshoot effectively. – caliban Sep 3 '09 at 6:22
OK, I'll add as soon as I can – Artyom Sep 3 '09 at 6:43

Try disabling your NIC in BIOS. Boot your computer and you might be surprised to find the video working correctly. Then reboot and enable the NIC in BIOS. Upon booting, both are working fine. There is some hardware or interrupt conflict that the OS cant resolve when both are being detected at the same time...

This fix has worked for me in both Linux and Windows.

share|improve this answer

There has been reported problems of the G41 chipset when used with older distros and kernels - reportedly the issue has been cleared with 2.6.28 kernels and above.

I recommend you :

  1. update to the latest stable kernel
  2. also, there are some reports that the new HDCP content protection settings in BIOS might interfere - PAVP or something. Hunt and disable if found.
  3. do an update for latest packages (apt-get -u upgrade)

For LAN - don't bother, just go out there and buy a supported LAN card and plug it in.

Let us know what's the outcome(s).

share|improve this answer
About LAN -- I have only 2 PCI slots... One I already use for additional LAN I don't want to use both of them for LAN. – Artyom Sep 3 '09 at 6:44
Oh, you got two 10/100 points from your PC? 1 is on the mobo, and 1 is on the PCI? – caliban Sep 3 '09 at 7:19
Yes. I need two -- one for modem and another for Cross-X-Cabel. Only the PCI LAN is recognized – Artyom Sep 3 '09 at 7:34

Hard to see if anyone actually answered or found anything usefull, so here's a suggestion you can drop if a solution's no longer needed.

I often find that some of the Live distro's find nice creative ways to solve hardware issues with hard to sove hardware issues. So what I usually do is get some of the latest Live distro's available boot them and leech the logs from these as they start X or whatever I need to snif.

Could be worth trying if you didn't get the problem solved.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.