Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It seems after about 5 minutes an inactive ssh session is terminated. The server is Ubuntu. How can I change this?

share|improve this question
add comment

migrated from stackoverflow.com Oct 17 '11 at 19:22

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 4 down vote accepted

On the server, login as root and edit /etc/ssh/sshd_config and add the line:

ClientAliveInterval 60

man sshd_config:

Sets a timeout interval in seconds after which if no data has been received from the client, sshd(8) will send a message through the encrypted channel to request a response from the client. The default is 0, indicating that these messages will not be sent to the client. This option applies to protocol version 2 only.

You'll need to restart the sshd for it to come into effect.

Alternatively on the client edit /etc/ssh/ssh_config (if you have root and want it for all users) or ~/.ssh/config and add the line:

ServerAliveInterval 60
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.