Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to make a USB bootable disk of Windows 7 ISO.

My USB is formatted to NTFS, ISO is not corrupt. I can copy install.wim elsewhere but I cannot copy it to USB. I even tried rsync.

rsync error

rsync: writefd_unbuffered failed to write 4 bytes to socket [sender]: Broken pipe (32)
rsync: write failed on "/media/52E866F5450158A4/sources/install.wim": Input/output error (5)
rsync error: error in file IO (code 11) at receiver.c(322) [receiver=3.0.8]

Stat for windows.vim

  File: `X15-65732 (2)/sources/install.wim'
  Size: 2188587580  Blocks: 4274600    IO Block: 4096   regular file
Device: 801h/2049d  Inode: 671984      Links: 1
Access: (0664/-rw-rw-r--)  Uid: ( 1000/    umur)   Gid: ( 1000/    umur)
Access: 2011-10-17 22:59:54.754619736 +0300
Modify: 2009-07-14 12:26:40.000000000 +0300
Change: 2011-10-17 22:55:47.327358410 +0300

fdisk -l

Disk /dev/sdd: 8103 MB, 8103395328 bytes
196 heads, 32 sectors/track, 2523 cylinders, total 15826944 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1   *          32    15826943     7913456    7  HPFS/NTFS/exFAT

hdparm -I

SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 00 00 00 00 20 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

ATA device, with non-removable media
    Model Number:       UF�F�A����U]r���U   u��tF�f�`~
    Serial Number:      �@󾽀~|
    Firmware Revision:  ����V�
    Media Serial Num:   $I�vnladip raititnot baelErrrol aoidgn
    Media Manufacturer: o eparitgns syetmiM
    Used: unknown (minor revision code 0x0c75) 
    Supported: 12 8 6 
    Likely used: 12
    Logical     max current
    cylinders   17218   0
    heads       0   0
    sectors/track   128 0
    Logical/Physical Sector size:           512 bytes
    device size with M = 1024*1024:           0 MBytes
    device size with M = 1000*1000:           0 MBytes 
    cache/buffer size  = unknown
    IORDY(may be)(cannot be disabled)
    Queue depth: 11
    Standby timer values: spec'd by Vendor
    R/W multiple sector transfer: Max = 0   Current = ?
    Recommended acoustic management value: 254, current value: 62
    DMA: not supported
    PIO: unknown
       *    reserved 69[0]
       *    reserved 69[1]
       *    reserved 69[3]
       *    reserved 69[4]
       *    reserved 69[7]
    Master password revision code = 60253
    not supported
    not enabled
    not locked
    not frozen
    not expired: security count
    not supported: enhanced erase
Integrity word not set (found 0xaa55, expected 0x80a5)
share|improve this question
Have you got another USB device to try? – Ƭᴇcʜιᴇ007 Oct 17 '11 at 20:44
all the others are less than 4gb. yet, i've seen that many people had experienced this problem, so it should be irrelevant from the usb device; yet hdparm results are little confusing – Umur Kontacı Oct 17 '11 at 20:46
According to what you've posted, the install.wim is 2.1GB (2188587580), so that should fit on a USB that's <4GB (but >2.1GB)? The hsparm info under "Model", "Media Serial" and such is pretty sketchy looking, hence why I suggest trying another USB device :) – Ƭᴇcʜιᴇ007 Oct 17 '11 at 20:49
all the flashdrives i have are 2 gb right now, except the one that i am using =( – Umur Kontacı Oct 17 '11 at 20:53
possible duplicate of Creating a Windows XP installation flash drive in linux – Ƭᴇcʜιᴇ007 Oct 17 '11 at 21:11

10 Answers 10

I had the same problem copying install.wim to USB flash drive (I tried several), so I changed the cluster size.

Right Click the drive, under USB, select Format, then change cluster size from 4096 (default) to 16 Kilobytes, and try to copy install.wim again.

share|improve this answer

Well, the reason for this problem is because the file is >4.0 GB in size and the USB is formatted in FAT32 format. The max file size for FAT32 is 4GB. The max file size for FAT16 is only 2GB.

So how do you fix this problem? Well there are two ways you can go about it. You can either split the file into smaller pieces and then copy it to your external hard drive or you can convert the file system to NTFS, where there is no limit on file sizes.

share|improve this answer

What is the error message when you try simply copying the file? Can you copy other things to the flash drive or simply touch a file on it? It's possible that one of three things is happening here:

  1. Your flash drive's filesystem is in a bad state, and you can't read/write to it. In this case, a reformat may help you out.
  2. It's possible that, because the install.wim is so large, that your filesystem can't handle the size of the file. Again, a re-format with the appropriate block size may help you out.
  3. The flash drive itself is dead. If a re-format doesn't fix the drive, you're better off finding something else.

You should be able to pick up a cheap 4GB for as little as $4 USD, so it shouldn't be the end of the world if it is indeed dead.

share|improve this answer

This doesn't address the specifics, but when creating bootable USBs from ISOs I have never run into a manual copying process. I usually use something like unetbootn as described in Create bootable windows 7 usb drive have you tried something like this?

share|improve this answer
Of course I did=) I do use unetbootin for creating bootable usbs for linux, but for windows, the process is a little bit complicated. You have to copy the files and write a MBR for your windows version yourself. – Umur Kontacı Oct 17 '11 at 21:00
It says that unetbootin can also prepare bootable usb's for windows but in my case it failed and it throw me to the boot console. – Umur Kontacı Oct 17 '11 at 21:06

If unetbootin doesn't work, as @Dennis suggested, try YUMI (similar to unetbootin/universal USB installer). I can give it a .iso of a windows installer and a thumb drive, and it works like a charm. If it can't, it usually gives informative error messages.

share|improve this answer

I just had this problem. I copied all other files seperately and left the install.wim until last. When I did this I walked away. It took about 5-10mins but copied successfully.

share|improve this answer

I know this thread is a bit old, but in case anybody has this issue. My ISB flash drive is 130gb and formated ntfs and boots to Win PE 4.0. I still had the Error that install.wim was too large to move over. so I simply copied the .iso over to the flash drive and used 7Zip to extract to a folder booted to WinPE dropped to D Drive and went into teh Win7x64 folder and ran setup. OS installed

share|improve this answer

Also came across this old thread and thought I'd share my answer...

Check if the USB set to fat32. If so, I think the max file size is 2gb and install.wim is around 2.57gb. Try formatting the USB to ntfs and try again. This worked for me.

share|improve this answer

Right Click the drive, select Format, then change cluster size from 4096 megabytes (the default) to 16 Kilobytes and filesystem to exFAT and now try to copy install.wim again.

share|improve this answer

I've come across that problem myself while creating a bootable USB.

  • On my first try, the copying process just stopped/froze.

  • The second try, with Total Commander - same thing 99% and that's it.

  • Third try (success), just regular copy/paste from Win7 CD/DVD -> USB and the same story, but this time I just let it be.

That third try, the time remaining started increasing but after 5 min progress bar moved again and the copying process was completed successfully.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .