Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a HP Pavillion dv4 laptop that is in the process of eating its (second) hard drive due to heat issues (have since gotten it a thermal cooler pad). I purchased a 1.5TB external usb drive to back up to, with the intention of using clonezilla to write image files to the backup drive, and then duplicity (primary OS is Ubuntu) to do incremental backups.

The problem is when I boot clonezilla live from a CD, it runs thru everything, making a backup image of the various partitions (including the big 385GB Windows partition) but when it goes back through and tries to verify the image, it gets a CRC read error every time on sda1 (the Windows partition). The other partitions (Windows rescue, / and swap) all verify fine.

So... my question is this: what are my options at this point? I really don't want to lose whats on my Windows partition if I can at all avoid it. Yes, I do have HP system rescue CDs available, but that will probably involve wiping out my Linux install and restoring that from scratch as well - which kind of invalidates all the time I've spent running clonezilla on this machine thus far.

Ideas, comments, suggestions?

share|improve this question
    
Have you run a disk check on both the source and target disks to ensure there are no data errors or disk defects? –  Ƭᴇcʜιᴇ007 Oct 18 '11 at 4:07
    
chkdsk /r c: when booted in windows. It will ask to schedule it at next boot, say yes, and reboot to windows. The /r will do a full scan and relocate any dodgy sectors. –  Paul Oct 18 '11 at 4:16
    
I haven't ran a disk check on the target disk as it is brand new and freshly formatted with no errors - and all the other partition images check fine. I ran the command 'chkdsk /r c:' as mentioned, and it found and supposedly fixed a number of errors. Then I ran clonezilla again... and it barfed on the same CRC error at pretty much exactly the same spot - 36% of the way thru the image for the 385GB Windows partition (sda1). –  memilanuk Oct 20 '11 at 2:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.