Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Gnome have a lot of system-wide keyboard shortcuts that have conflict withs application-wide keyboard shortcuts.

Windows avoids such conflicts by using a dedicated key (super/window/OS key). For example in Ubuntu Alt+Shift+Up has a conflict with "move up line" in phpStorm. (Linux shortcuts have precedence to application-wide key, and I can not disable some of them.)

  1. How can I disable all Gnome keyboard shortcuts?

  2. Is there any app to map Gnome keyboard shortcuts to super key (or perfectly map to Windows equivalent keys)?

  3. Essentially, why do Linux developers not use the super-key as an modifier key for OS-wide actions?

share|improve this question

migrated from stackoverflow.com Oct 18 '11 at 6:17

This question came from our site for professional and enthusiast programmers.

1  
@Ignacio Vazquez-Abrams programmers extensively use shortcuts in IDEs. –  Reza Oct 18 '11 at 4:20
3  
That's nice. I bet it also affects users of My Pretty Pony too. But that still doesn't make it a horse-rearing issue. –  Ignacio Vazquez-Abrams Oct 18 '11 at 4:21
    
You should specify which version of Ubuntu. If Ubuntu 11.10, you should specify whether you are running Unity or GNOME (those are different things). –  gpoo Oct 18 '11 at 7:59
    
@gpoo I use Ubuntu 11.04 –  PHPst Oct 18 '11 at 8:07
add comment

2 Answers 2

An alternate solution to your problem that might be more palatable for you is to change the keymap in PHPStorm to "Default for GNOME". This will change the keyboard shortcut combinations so that conflicts with GNOME are removed. I believe PHPStorm installs with "Default for XWin" as the default keymap, which includes shortcuts keys like Alt+F8 and Alt+F9 that conflict with GNOME window Window Management keyboard shortcuts.

Go to File -> Settings and select Keymap in IDE Settings. Here's a screenshot with the relevant dropdown circled in PHPStorm keymap:

enter image description here

Hope this helps.

share|improve this answer
add comment

Ubuntu 11.04 ships by default Unity. It also ships GNOME 2.32 (named 'GNOME Classic' when you want to start the session).

GNOME does not set Alt+Shift+Down. So, if you are using GNOME, either:

  1. You set the 'Compose' key by mistake in a different key. Go to System-Preferences-Keyboard-Layout and choose the button 'options'. The customizations are in bold.
  2. You set it manually (or by mistake) in the global binding. Go to System-Preferences-Keyboard Shorcuts.

Also, GNOME ships metacity as window manager, but Ubuntu ships compiz by default. So, to disable compiz:

  1. Go to System-Preference-Appearance-Visual effects and set it to None. The keybinding should change.

However, I think you are running Unity (with compiz). In this case you should:

  1. check a similar answer in askubuntu
  2. Edit your question and change 'GNOME' by 'Unity'.
share|improve this answer
    
1- Please consider shift+alt+up 2- I do not use Unity (I use classic interface). –  PHPst Oct 18 '11 at 12:13
    
I added the instructions to disable compiz when using GNOME. –  gpoo Oct 18 '11 at 17:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.