Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a CSV file which I can open and view the column with Chinese letters normally with TextMate.

However, when I try to import this file into Excel 2011, the field comes with unreadable fonts. When I copy and paste this into a text-only software (TextMate again or even this textarea box) I see that it is shown correctly.

Maybe my trouble will be solved if I could select the appropriate font in Excel, I'm not sure. As I do not speak Chinese, I do not know what to choose.

I kindly request some help from Chinese speakers out there, do I need to:

  • install special fonts?
  • choose the appropriate font (which is already on my computer perhaps)?
  • install the chinese input capability to my OS?
share|improve this question

1 Answer 1

up vote 1 down vote accepted

You don't need special fonts. It sounds like you have a problem in which excel is misunderstanding what the encoding of the file is.

Here's how to solve it. On the data menu, choose "get external data", navigate to the file. Now, in addition to the usual csv import options, you can tell excel what the file origin is. UTF-8 would be a good guess.

share|improve this answer
    
I imported the data to mySQL and then worked on it. Thanks to you, now I know how to do it in Excel, too :) –  cenk Dec 13 '11 at 23:03
    
I get 3 options, Mac, Windows(Ansi) or DOS/OS2 - no utf options in Excel 2008 for Mac –  mplungjan Jan 3 '12 at 9:44
    
Even when selecting UTF-8, Excel messes up the encoding. Tried all variations for UTF-8 and UTF-16 with and without BOMs in the CSV file... Just an anecdotal bug report(?). –  deceze Nov 7 '13 at 8:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.