Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Up until a few days ago, I was able to access services that had been port forwarded on my router. I'd like to be able to do that, as I have services that I like to use on my laptop both at home and away from home and not have to switch the ip addresses for the apps to those services.

How do I fix this problem?

I'm using Comcast, a SurfBoard SB6120, and a Linksys E3000.

share|improve this question
1  
I assume the user e.g. is running some server on a desktop computer and has the laptop configured to always access the router's public IP address even when home. Just posting this comment as I had to read the question twice before it made sense. –  Daniel Beck Oct 18 '11 at 18:01
add comment

migrated from stackoverflow.com Oct 18 '11 at 17:54

This question came from our site for professional and enthusiast programmers.

2 Answers

up vote 0 down vote accepted

Make sure the Filter Internet NAT Redirection checkbox is unchecked in the router's settings, as shown in this screenshot:

Screenshot of Linksys E3000 web UI

Having that setting enabled is one of the things that would cause the symptom you're seeing.

share|improve this answer
    
Awesome. Thanks. –  jason Jul 17 '12 at 20:22
    
Just for fun, why would you want to filter it? –  jason Jul 17 '12 at 20:38
    
@jason: No reason I can think of, besides having an application hosted on your home network treat external access differently than internal access. One would almost never have a use for this except in a corporate setting. (Say, sending www.anycorp.com visits from inside the LAN to the Intranet site instead of the public one.) –  David Aug 21 '12 at 18:03
add comment

The most likely reason is the ip address of the computer you where port forwarding to has changed. Check the IP of the computer and see if it matches the IP on the port forwarding setup page in your router.

As some general advice, if you are setting up port forwarding you should either set that computer up with a static IP so this does not happen again or see if your router can reserve a IP addresses to the computers MAC address so it will give the same IP every time when it assigns a DHCP address.

I do not know if your model router supports reserving DHCP addresses, but many modern routers do.

share|improve this answer
    
I have set up the router to assign an ip address (192.168.78.2) by the mac, so the ports are fine. I'm also able to get in through an external network like work. –  jason Oct 20 '11 at 1:42
    
Then I am confused by your original post. Can you re-word it to make it more clear on what you want and what is not working. –  Scott Chamberlain Oct 20 '11 at 13:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.