Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm unable to figure out why this one computer on a network cannot resolve URLs. When an address is typed in, the message "Page cannot be displayed" is shown. When the IP is typed in, the page loads. Google was used as a test site.

  • The computer obtains a valid IP through the server.
  • The computer obtains a valid DNS through the server.
  • There is no proxy.
  • There are no erroneous HOST file entries.
  • Windows Firewall is off and no other firewall programs are loaded
  • Cannot ping sites with URL. (i.e. receives "Ping request cannot find host")
  • Can ping site if IP is used instead of URL. (i.e. "Ping replies received")
  • DNS service on workstation was stopped and started.
  • Computer was rebooted as well as cold booted.
  • Changing the DNS manually to different servers did not fix. (;;; internal DNS)
  • IPCONFIG /flushdns after each DNS change did not fix.
  • IE, Firefox, Chrome are all affected.
  • No malware detected on full scan using AVG, Malwarebytes and SuperAntiSpyware.
  • Checked for rootkit with TDSSKiller and none detected.
  • Server is able to browse without issue.
  • Other computers on network can browse without issue.

Any suggestions for what to try next or ideas about what is possibly going on would be appreciated.

share|improve this question

You want to a use a tool called nslookup. This is command-line tool that is included with Windows, so you already have it. Just open a command prompt, type nslookup, and press enter. Then you can start entering names to resolve. You can change the server it checks against by type "server x.x.x.x", where x.x.x.x is the IP of the new server. Type "quit" when finished.

The other thing I would check is IPv6. You may have a dns server that's returning IPv6 addresses, or a machine that is sending out IPv6 address requests, and then a browser that only knows IPv4 routes to the web.

After that, if and only if you still haven't found the problem, you can try a reset of your ip stack. From a command prompt:

netsh int ip reset resetlog.txt

share|improve this answer
Argh... +1 Beat me :P FYI, but you probably know - I only learn't yesterday during some DNS troubles here that you don't need the server command... If you are doing just one lookup for example, you can type "nslookup target server" ! I may be sad, but, I thought it was pretty cool when I found that out! – William Hilsum Oct 19 '11 at 2:47
nslookup returns correct entries. I confirmed the server is not returning IPv6 addresses. I ran the command but it did not resolve the problem. – Mirage Oct 19 '11 at 2:57
up vote 1 down vote accepted

After all the other suggested options did not work to resolve the problem, I tried a repair install of the OS. I still don't know the root cause of the issue, but that corrected the trouble and the computer can browse normally again.

Thanks to everyone for trying to help figure out the cause.

share|improve this answer

When you ping an address say - does DNS resolve and show the IP address or does it say that the host cannot be found? (Checking if DNS is up)

If it does resolve the address, can you use the IP address directly into the browser to go to the site? (Checking if DNS resolving correctly)

share|improve this answer
Unable to resolve URLs, but able to ping IP addresses. – Mirage Oct 19 '11 at 2:11

I had a similar (but not quite the same) problem a few weeks ago on a Windows 2003 Server. I could ping by IP address but didn't get name resolution even though the DNS servers were setup correctly. Also had some strange characters in place of the hostname when pinging (ping -a x.x.x.x). It was fixed by resetting Winsock:

netsh winsock reset catalog

You'll then need to reboot before you try again.

share|improve this answer
I tried the command and rebooted. Computer is still unable to resolve DNS. – Mirage Oct 19 '11 at 20:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .