Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just downloaded and installed the Ubuntu 11.10 on Virtual Box. It worked fine and gave me a nice GUI desktop at the end of it. I then had a problem with host rebooting (seems to be related to 64-bit hardware virtualisation), so I installed VMware Viewer.

Now, when I installed with VMware I end up with a command prompt, not a GUI. Why is that?

And how do I get from the command prompt to the desktop?

share|improve this question

2 Answers 2

There could be two possible reasons, depending on the version of VMware and the recent changes in 11.10: (Disclaimer, I haven't yet tested 11.10 so I'm basing my knowledge on 11.04; I expect it to be the same behaviour though.)

  1. When you created your VMware virtual machine, you were given the option select your guest OS (I know this is true for VMware Workstation 7.x and earlier, I haven't tried later versions or other products, but it's likely suite-wide.) Anyway, if you select Ubuntu during this configuration, VMware performs additional post-installation set-up that should activate video.

    BTW, when booting the Ubuntu ISO, you should be given the option to boot boot the "Live read-only" desktop, and to install locally. Does booting the Live desktop give you a GUI?

  2. VMware requires specific video drivers to properly display an emulated desktop interface. Most of the time, the vesa drivers should kick in allowing you at least some form of UI, but with the recent introduction of Unity (and the 2D/3D acceleration it requires) vesa may be having issues. Even if you install to a command-line only interface, you can install the VMware Tools packages to set up the new drivers for X.

    Please refer to the instructions for your specific VMware product for the steps to install VMware Tools.

Hope this helps.

share|improve this answer
up vote 1 down vote accepted

My bad. With VMWare, the process had halted and dropped me to the console because it couldn't download Guest Additions. I restored my internet connection, deleted the machine and started again, and all was fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.