Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Hibernate (i.e. KDE Kickoff - Leave - Hibernate), I immediately get a black screen with those two lines: PM: Syncing file systems ... Freezing user space processes ...

A few seconds later, the screen turns black, but instead of hibernating, the session is locked. When I move the mouse, I can enter my password and I'm back where I started. Only the NIC seems to be temporarily deactivated.

OS: Fedora 15 uname -r: 2.6.40.6-0.fc15.x86_64 MB: Asus SABERTOOTH 990FX

share|improve this question
1  
Do you have a working swap partition? (Post the output of cat /proc/swaps if you're not sure.) –  Patches Oct 19 '11 at 8:45
    
Yes, I have a 5 GB swap partition. –  basic6 Oct 19 '11 at 15:14
    
Try the debugging steps listed here and let us know if they work or fail. –  Patches Oct 19 '11 at 16:40
    
Upgraded to Fedora 16 (all updates installed), same issue. From your link: Neither one of those first two commands (echo reboot > /sys/power/disk...) hibernate my system. I can't be the only one having this problem...? –  basic6 Nov 26 '11 at 12:54
    
In that case, I would file a bug against the kernel. Include all the details you can from the debugging steps you performed and complete information about your hardware. (An easy way to provide a hardware profile is to run smoltSendProfile and provide the link it outputs in your bug.) –  Patches Nov 27 '11 at 1:33

3 Answers 3

Check your computers BIOS setup, - some have an option to set the suspend-level to either standby or hibernate.

share|improve this answer
  1. You are running an old version of the Linux kernel.
  2. Hibernate on Linux, as of late, almost never works. To debug this problem will require you compile the kernel with CONFIG_PM_DEBUG.
  3. Most users can't debug these problems, so if you really want hibernation to work, you can consider changing to Ubuntu, but there is only a small chance this will help.

See this guide: http://www.kernel.org/doc/Documentation/power/basic-pm-debugging.txt

share|improve this answer
up vote 0 down vote accepted

Patches was actually right, it was the swap partition, which was too small (< RAM). I should have realized that.
All the other comments/answers are valuable too, thanks for all those tips.
@Patches, if you write an answer, I'll delete mine and accept yours.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.