Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having internal network speed issues on my network. The Server (Windows 2008 R2) has two network cards. One provides 802.1x authentication to the outside world. The second, shares this using ICS to other devices on the internal network. The server also acts as a DNS and DHCP Server (DNS primary is set to my server, secondary is that of the external network.

All these devices are connected to a TP-Link TL-SG2109WEB Gigabit managed switch, with 80.211q VLANs – The server and Wireless AP are in both VLANS because the Wireless has multiSID VLANs.

The main problem, as soon as I power the server, the network speed immediately begins to drop within the internal network, within 5 minutes the transfer speed of anything internally is ~100kbs/s when at the beginning its over 50MB/s.

All NICs on the networks are 10/100/1000, so I know that is not the issue.

Solutions tried so far:

  • Alternative unmanaged switch
  • Different CAT6 cables
  • Removing network devices

Any ideas anyone can throw at me would be much appreciated.

EDIT 1 - additional info

I should have also mentioned that sometimes (often after several successive reboots of the entire "internal" network, including server) the internal netowrk works fine, with all transfers above 50MB/sec

EDIT 2 - MTU Changes

Changing the MTU down to 800 on both server and computers failed to solve the problem.

share|improve this question
    
Sounds like the server is flooding the network with traffic. Can you monitor this on your switch or install a program like peerblock to monitor traffic? Have you checked for viruses? –  Yeodave Oct 19 '11 at 11:32
    
@Yeodave : Virus free and when you monitor the network, there is no traffic apart from standard background. The external network connection is also idle apart from again standard background. Checked with wireshark, Just a strange lot of "TCP Segment of a reassembled PDU" between the server and a desktop –  schuhmi2 Oct 19 '11 at 11:59
    
check MTUs on both links, server load (probably). Can you name used NICs? –  Lazy Badger Oct 19 '11 at 12:53
    
@LazyBadger : MTU on all network connections is default (1500). The server has 2 NIC's, one for internal, and for external (another network which provides internet but has 802.1x authentication) All other devices have the same problem on the internal network, whether ethrenet for wireless connection. However the external connection on the server is fine - I can go on it and download a 1GB file in just over 1 min. NOTE: I also have (or just am about to) add an extra piece of info to the main question. –  schuhmi2 Oct 19 '11 at 13:34
    
did you tried to minimize intranet and have in it only one additional host, connected to server by crossover? Did you tried to disable WAN interface on server? and yes, monitor internal speed in both cases –  Lazy Badger Oct 19 '11 at 13:59
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.