Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed the Visio 2010 viewer.

How do I now make this viewer to open if I double click a VSD files? Every time I do so only my web browser (Opera) is started - but it is not associated with the VSD file extension.

I tried to manually assign VSD files to the viewer but I wasn't able to find the viewer executable file.

share|improve this question
Despite the name, Visio 2010 viewer, is not a stand-alone application, but it is a plug-in to Internet Explorer. As such it does not really work well. For instance, for printing properly, there is often no other way than to zoom, take a screenshot, crop (in, say, Paint) and print out through some other program, say Word. – Peter Mortensen Apr 19 '13 at 11:18

The site to which you linked says the viewer only works in Internet Explorer 5 through 8.

Visio Viewer is implemented as an ActiveX control that loads and renders Visio drawings inside Internet Explorer.

This download works with the following program: Microsoft Internet Explorer 5, 6, 7, or 8.

share|improve this answer
If I associate VSD files with IE then Opera comes up as it is my default web browser. Stupid IE. If I start iexplore.exe from command line with the VSD as parameter it works!? – Robert Oct 19 '11 at 17:25
up vote 1 down vote accepted

I found a solution:

The problem is that the registry entries are incorrectly set by the Visio Viewer installer.

You have to delete the registry key


Then you have to add "%1" to the value of


so that it looks as follows:

"C:\Program Files\Internet Explorer\iexplore.exe" -nohome "%1"
share|improve this answer

Make sure that the "Microsfot Visio Document" add-on is not disabled in Internet Explorer. You can see the installed add-ons in Internet Explorer, under:

Tools button (upper right hand corner) > Internet Options > Programs tab > "manage add-ons" button

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.