Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I guess I know the ultimate answer already but there's too many variables that don't line up for me to be satisfied with it.

Last night and this morning I was shrinking partitions using Windows Storage Manager and Ubuntu's/GRUB's built in partition manager. Everything was fine, I installed Partition Magic in Windows as it became evident I needed to move free space around the drive but it gave me an error about an unrecognisable drive letter which it says is normal for some OEM installations.

All fine so far, so this morning I attempted to delete one of the partitions created using GRUB and Windows gave me an error about insufficient resources. That didn't make sense with 4GB of RAM and 2.2GB in use. I attempted again to delete the partition and it froze for a solid hour while I worked away in the background. I hard reset it and it stuck on the Windows startup screen, here's where it goes wild.

So starting in safe mode brought me to classpnp.sys, Lenavo one click restore froze on loading files and the Ubuntu installer gave me an error about insufficient memory at startup from a USB drive.

I opened her up and tried each memory stick on their own, same result. So then I removed the hard drive and put it into an external hard drive case and tried it in a few other computers all with the same result.

It says installing drivers and stays on installing NSI External Drivers until I remove it and then it will say finished. When I plug it back in it doesn't show anywhere except Device and Printer manager where it just says External. Clicking on the properties dialog and double tapping the NSI driver hangs the properties dialog.

To me it seems the drive is a goner, but I'm not convinced how as it was working fine before nmy partition messing and if it were a partitioning problem it should show up as a drive nonetheless unless something in the computing world has changed as of late that I'm unaware of.

Any ideas as to how to proceed? I could really do with the work I was doing this past day or two!


EDIT 1: Ok after some playing around with low level partition managers via Ultimate Boot CD I've progressed a little. First I can now enter all of the utilities that are on the utility partition. And now it also shows up when I put it as an external USB drive. In Partition Recovery application it shows the partition and it's contents but no recovery option. Weird eh? It also shows the drive letter as *. Still not sure how to proceed at this point.


EDIT 2: Ok I managed to get it to show me the hard drives by activating another partition using a low level partition tool and then re-activating the original partition. Now the mad part, Windows 7 seems to have created a 200mb partition at the beginning of the drive, if I load the second partition it lists my folders in EASUS Partition application but I can't recover it, the option is disabled. I've just created an entire disk image. I am thinking I can just delete the first hard drive and set the start of the second to 0?

share|improve this question
    
Have you attempted to boot to a Linux Live CD to extract your files? If you cannot see the drive in Linux you may be out of luck. –  jmreicha Oct 19 '11 at 20:29
    
GRUB won't load, as I said I get a memory error for any option including disk and memory check! –  Jay Oct 19 '11 at 20:46
    
Booting to a Live CD will bypass GRUB and the problems you are facing, I think, giving you a chance recover your files. From the BIOS select boot from CD-ROM. –  jmreicha Oct 19 '11 at 20:55
    
The GRUB loader is on a USB key –  Jay Oct 19 '11 at 21:01
1  
What exactly is the grub error you are getting? –  Paul Oct 19 '11 at 21:06

1 Answer 1

First of all...

#1 Rule of Partitioning:

Avoid mix-and-matching tools, unless you really know what you're getting into!

I've managed to delete partitions when using different tools quite easily, often because of alignment requirements that don't match or because entries don't get put in the correct order.

(It seems like a trivial issue, but it's very complicated, because of how many backward compatibility issues there are.)


That said, I think this has nothing to do with your drive failing. It probably isn't. Rather, perhaps the partition table is invalidated, and Device Manager is getting confused?

What I would recommend:

  1. Try taking an image of the drive before doing anything. (It might be possible for the drive as a whole, even though the individual partitions don't show up.)

  2. Try and if you can undelete any partitions with a program like EASEUS Partition Recovery.

  3. Post any particular errors you might get, so that we can diagnose the results better.

share|improve this answer
    
Hi, thanks a lot for your comment, the problem I'm facing is it doesn't show up in any kind of device manager bar Devices and Printers where it only shows up as 'External' - will EASUES read it like that? I'm not sure how I'd go about taking a disk image at this stage either? I'm very familiar with partitioning and everything that goes with it. I used Windows to create the partitions and GRUB to format them that's why I didn't see a problem. –  Jay Oct 19 '11 at 20:42
    
@Jay: It might, but I don't know. Does Disk Management (diskmgmt.msc) show anything at all? And have you tried reading it with a Linux boot disc? (You might also find this read interesting, btw -- it taught me that partitioning is a lot more complicated than I'd previously thought!) –  Mehrdad Oct 19 '11 at 21:30
    
Yes it does now, but the drive letter is an asterix for the primary partition. It shows another 200mb partition before my primary partition which is weird as hell... –  Jay Oct 20 '11 at 20:37
    
@Jay: The 200-MB space is probably typical -- the Windows installer creates it in most cases, for recovery stuff. As for the asterisk, maybe the partition type in the partition table is messed up? Have you tried diskpart with select partition <number> and detail partition to see what it shows (e.g. what type)? –  Mehrdad Oct 20 '11 at 20:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.