Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having trouble with Java on a virtual server, it always gives me the following error:

# java
Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java virtual machine.

I first solved this by using the CACAO virtual machine (of OpenJDK, by putting it first in jvm.cfg), but then I run into problems with my web application (Play! framework based, gives me nasty LinkageErrors). So I cannot use that VM. Instead I'd like to just use the normal server VM and set -Xmx128M by default. How can I do that?

Related: this question

share|improve this question

Try the solution given on stackoverflow - which is to hard code your -Xmx and -Xms settings into the deps.py file in "framework/pym/play/commands/"

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .